Jump to content

CLI RasPi WiFi at my wits end!


anode
 Share

Recommended Posts

I can NOT get a WiFi adapter (various RealTek based ones on hand) to even associate from the command line.

GUI works fine. (But I don't use the GUI on a Pi.)

I've turned off (and even removed) NetworkManager.

ifconfig down/up the IF

iwconfig wlan(x) essid <network>

iwconfig wlan(x) essid <network> channel x

iwconfig wlan(x) mode managed essid <network> channel x

---All fail. (with no message)

(also tired using iw dev wlan connect <network>)

iwlist scan does show the APs being there.

Even on open networks, including the WiFI-Pinapple.

(Now I can get airmon-ng with work with them OK.)

Raspbian and Kali images both give same results. (going to try the old PwnPi)

The GUI vs CLI has got me stumped.

Link to comment
Share on other sites

remove it, dmesg, then plug it in and do a dmesg again, any errors? ifconfig -a, does it shows the device is plugged in? When in the command line, you may(depending on how you have the users setup) need to use sudo to start and stop the adapter, unless running as root, but check the obvious first, then see what happens with sudo if you weren't already using it. With kali, if live booted, you're most likely already root and don't need sudo but just throwing things out there.

Other thoughts, aircrack may be loading the drivers or custom drivers, although I don't fully know if they load their own generic wifi drivers, try lsusb and see what kind of info you get back when the device is plugged in

Edited by digip
Link to comment
Share on other sites

i have turned one of my pi's into a long range repeater, spent long nights testing and writing configs.

Its been a while but ill try to post a few examples.

Always monitor your testing well running in a second terminal/ssh session

Tail -f /var/log/kern.log

I have noticed a few routers are stubborn and your wpa.conf will need some messing with, so try other access points, open and secure... ill sometimes turn my phone into a access point...

step one, turn off all services that mess with your adapter... this is a manual configuration...

Here is one that may be the culprit

EDIT-> etc/network/interfaces

Auto Wlan0

Iface wlan0 inet manual

root@iphone:~# cat golf7376.conf

network={

ssid="golf7376"

psk="Family1234"

#psk="37710101"

#psk=be418f66bcde9eff3c3bcf6ed0dce7622dd7796fedf7f78950760fcb432f69a8

}

This is a example wpa_supplicant conf, follow wpasupplicant tutorials... execute the config like this

wpa_supplicant -Dnl80211 -iwlan2 -cgolf7376.conf -B

At this point you should watch the console that is tailing kern.log

Then dhclient wlan0

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...