Jump to content

Pinneapple V; Kali & Dell XPS 13 (9333)

Recommended Posts

Hi all,

I'm having some issues trying to get an internet connection to my Pineapple V. I've got Kali 1.1.0 installed on my Dell XPS 13 (9333), and I use a USB to Ethernet adapter to be able to link the ultrabook to the Pineapple. So, I've got my eth0 interface working and I've got my wlan0 interface connecting to my router for an internet connection, but I can't get wlan0 to share to eth0 to update my Pineapple.

Has anyone managed to sort this issue? I've tried using the MkV .sh script and it doesn't seem to work...

Many thanks all!

Link to comment
Share on other sites

Honestly if you're trying to like get internet on the Pineapple so you can download infusions i'd recommend you login to the Pineapple over Ethernet then go to network title from then click on Client Mode and locate the network you own that you wanna have the pineapple share the internet with.

I've made a video on how to use Wireless from another network to give the Pineapple internet if that's what you're trying to do.

im not sure i fully understand what you're trying to do but then again i have been up for over 18 hours without sleep so im not thinking straight.

If you're wanting to upgrade your firmware i myself don't trust the over the air part i prefer to download the firmware and upload the firmware using wget and then installing the firmware via ssh i've done videos covering that they can be found in the WiFi Uni section.

Link to comment
Share on other sites

I have the XPS12 and when it ran Kali the script worked just fine. Did you set the eth0 ip address first?

Yea, just booted Kali, set the usb ethernet's ip to, then ran the wp5.sh script. Pineapple can connect to the internet after that.

Edited by barry99705
Link to comment
Share on other sites

Hi Barry, did you just use ifconfig to do that and did you change anything else in the script process?

I replied in DM, but I'll throw it out here as well. It will work both ways. I usually kill network-manager though. "service network-manager stop" I've had the laptop get a dhcp address from the pineapple and kill the internet connection.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...