Jump to content

Internet but no DNS resolve


Recommended Posts

I just become my Pineapple. I've installed it, connected it via LAN to Notebook. The Notebook was connected over WLAN to Internet.

I'm using Windows. Sharing of WLAN Adapter is enabled.

LAN Connection (to Pineapple) configured:, Subnet:, Default Gateway: none, DNS

Connection form Notebook to Pineapple works fine. Connection from Smartphone to Pineapple works fine. But no DNS was resolved.

Ping (via Putty) to www.google.com was not working.

Ping to (IP of google.com) was working.

With Smartphone: when I go to www.google.com -> Site was not resolved. When I type in browser: google.com was showing.


Destination Gateway Genmask Flags Metric Ref Use Iface
default UG 0 0 0 br-lan * U 0 0 0 br-lan

What do I making wrong?

Link to comment
Share on other sites

Set a DNS server for the pineapple most likely. This question should(and may already be asked and answered) be in the Pineapple section of the forums though, so other Pineapple users can read up on the same issue and find a way to resolve it.

I don't own a pineapple, but if like any linux system, you probably have a resolv.conf file in etc(not sure if the pineapple has it's own DNS service) but try and edit it and add a DNS server such as OpenDNS, ie:

nameserver    ip.of.main.gateway(willsometimes work too)
Link to comment
Share on other sites

Yes, Pineapple has a resolv.conf file also. I have alreay tried to edit this file. But after edit (and restart service or reboot Pineapple), my changes always are over written.

In resolv.conf stand:


I searched the forum, but can't find a post in forum for my problem.

A bit more of testing: When I edit the resolv.conf:


and save the file, in Putty I can Ping google.com and it's resolved. But connected Smartphone can't resolve (Smartphone was restartet first).

When restarting DNS service on Pineapple, my custom value for resolv.conf was overwritten with the initial value. DNS Resolve was not working.

Link to comment
Share on other sites

Without using DHCP or bridged to another gateway, you will probably have to enter a DNS server manually in the conf file. I wouldn't do it per site but instead add a real DNS server, not googles IP so that you can visit more than just google. This should still probably be in the pineapple section for the version you own though. I have a feeling most people are using some sort of infusion and attack against clients connecting and not using it as a normal AP, although it can act as a normal gateway, use a normal router if you want to just surf through it.


The post is a bit old, but might help. I'd say look in the sections for the pineapple that have the version you own, and read through posts about connection sharing. The forums search seams broken. I searched for "dns" and it returned nothing, but used google to find that link.


Link to comment
Share on other sites

  • 2 weeks later...

loop back would normally be, no? The loopback is usually only used for testing tcp service(s) and making local servers for the most part. Are you sure the other nic settings aren't just foobar or is this a normal part of the pineapples networking?

Link to comment
Share on other sites

Okay, thanks for your reply. I just try following. Instead of changing the loopback, iI have changed the infervace lan, and added the DNS there. The lan DNS entry was the Google DNS, so I changed it to Reboot the pineapple, and it works.

Was this the right (better) way?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...