Jump to content

After restart, can't access Mark V SSH or web interface via eth cable.


P Jones
 Share

Recommended Posts

Hey all, I just started with the Pineapple and WiFi hacking in general last week. I've had quite a few issues with the Pineapple, such as the interface becoming inaccurate or inactive (eg, the Intelligence Report being populated hours after clients have disconnected or the DNSSpoof failing to activate after the first use). But the worst by far is this: frequently after an hour or so of use, Karma will essentiall stop working. It will stop logging packets from SSIDs in the whitelist and it seems to stop creating honeypots altogether. If I restart it, when it comes back I can't connect to it via the ethernet cable, whether through ssh or the web app. I've had to reset it twenty times in the past week. Very frustrating.

When I try to ssh, I get:

@ubuntu:~$ ssh root@172.16.42.1
ssh: connect to host 172.16.42.1 port 22: Connection refused

I haven't the faintest clue what's happening or how to fix it.

It's set up in client mode, with an Alfa adaptor at wlan2 connecting it to the Internet. I've had the same results with Windows 7, Ubuntu, and Kali (ie it has crashed under all of them), in client and classic mode, and with and without the Alfa.

Also, I ran the Mk5 setup script on the Linux boxes, and I followed the Windows setup to the letter. Like I said, it works fine, and then nothing.

Let me know if I can

Link to comment
Share on other sites

Karma logs fill up quickly. Make sure you point Karma to somewhere on the SD card so it won't crash your system. The default location for the log should be in the /tmp directory so it will not persist between reboots but after about an hour of activity it could log a lot of info. There isn't a lot of internal space on the Pineapple to begin with so once it fills up the behavior can get wonky.

Link to comment
Share on other sites

So I had the Pineapple going for about an hour. I turned it off just to see what it would do. Same problem. Though I also noticed that Windows clients cannot connect to the management WiFi channel. Linux users can. Nothing can access The log, karma-phy0.log, is in /sd/, and is only 4.2k, so that clearly isn't the issue.

Anyone have any ideas?

Link to comment
Share on other sites

Since I know you are all waiting with baited breath: I half solved it. I have a third wlan which I've been using for Internet. It's in client mode, of course. I went into the networking infusion and switched it to classic mode, just to restart networking and now it's fine. Not really a solution, but at least I don't have to reset every time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...