Jump to content

aliases from .bashrc do not seem to load.


ghostish
 Share

Recommended Posts

When ssh-ing to the pineapple the alias definitions in .bash do not seem to load any pointers?

What I've tried:

Creating a .bash_aliases file rather than just chucking them all in .bashrc

Result: no change

Creating aliases directly on a per login basis

Result: works, but tedious

Doing the morally required pre-post googleing and searching through previous posts

Result: tried many but, running into mental 404's as far as search terms go.

Any help is greatly appreciated, I'm just drawing a blank.

Current .bashrc contents:

# If not running interactively, don't do anything

case $- in
*i*) ;;
*) return;;
esac
#check if .bash_aliases exists and execute
if [ -f ~/.bash_aliases ]; then
. ~/.bash_aliases
fi
#aliases for ease of use.
#ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'
alias ld='ls -d'
#misc helpers
alias del='shred -f -n 5 -u -v -z'
alias md='mkdir'
alias c='clear'
alias cls='clear & ls'
alias clip='xsel'
alias iv='vi'
alias up='ping -c 1 google.com'
alias nkey='ssh-keygen -b 4096 -t rsa'
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...