Jump to content

Connection Speeds with AWUS036NEH

Recommended Posts

Alright guys, just a quick query.

I've got my pineapple set up connected to my home access point through wlan2 (The Alfa from the hakshop). When just connected and the pineapple not running any other business I get a connection speed of about 4-5 MBps but I varies quite wildly and sometimes ducks down the below 1 MBps. However, once I start running the PineAP suite it drops completely to sit between 0.1 and 0.5 MBps.
I'm right next to my AP so it's not that. I've tested the Alfa on a laptop and ensured that it's still working fine. I also SSH'd into the Pineapple and used top to check ram and cpu usage. Both were sitting comfortably low.

Is this behaviour seen by everyone else, or is there a problem on my end that I've overlooked?


Okay, so after some more playing around, it seems the issue *may* be related to Harvester. With all the PineAP modules running plus Karma I get around 1.3 MBps. As soon as Harvester is turned on, it drops to about 0.1 MBps. ALSO, I keep getting random reboots which makes me think it could be an overloading problem?

I've since done a factory reset and updated to the latest firmware.

And I've double checked the power. Its got a solid 12W being pumped into it..

Edited by Xcellerator
Link to comment
Share on other sites

Alright. So your Bit Rate is similar as mine. Lets try this:

1) ssh into your pineapple and run the command "top".

2) Run PineAP and harvester like you were before and any other options you had running

3) Open another ssh session in a seperate window and run: bash -c 'while [ 0 ]; do iwconfig | grep "Bit Rate"; sleep 1; done'

Im curious to see if your Bit Rate drops whilst running. Mine varies between 52 Mb/s to 72.2 Mb/s.. With just PineAp and harvester etc running, the browsing is seamless. As soon as I start ettercap/sslstrip, it gets sluggish then hangs.

On a side note, after I stopped sslstrip and etterca, the nginx process hung and saturated the link between the pineapple and my laptop. When I browsed to, I get bad gateay. Only thing todo was reboot the pineapple. I think it's all load related, but in your case you didnt have any infusions running right?

Link to comment
Share on other sites

Right, here we go:

1) Throughout the whole process I had at least 50% idle cpu according to top.

2) The bit rate stayed fairly level, pretty much the same as yours but it spiked an awful lot. About every 10 seconds or so it'd drop for a second or two to anywhere between 1 and 40 MBps.

3) Once I threw on the whole PineAP suite and Karma, there was no effect on the bit rate at all, but after a short while my access to the Internet was lost. Nothing would bring it back up other than a reboot. I confirmed that connecting straight via the AP worked just fine.

After it all rebooted, I found the plot thickens even further. Before I rebooted it, I tried pinging the gateway and it gave me "Network Unreachable". After rebooting, it responded just fine. Then, about 3-4 mins after setting everything up running again, it goes again.

I'll add that this whole time, I've got download speeds of 0.5-1.5 Mbps according to speedof.me and speedtest.net. Connecting directly, I get a solid 20-ish Mbps.

(The reboot issue is the same as you described except I didn't have as much running, so at least that seems to be experienced by someone else. I've seen other people reporting *similar* things too on the ticket tracker).

Link to comment
Share on other sites

Hey Xcellerator,

I reached out to Seb and Darren over on twitter and a new firmware should be coming out shortly (Also, MITMf integration appear to be on the horizon! This is epic news, it's well coded, and should remove the need for other infusions which weren't running well on the MKV. Not sure if it will land in the next release though!) Hope fully over the next week or so we should see a release.



Edited by mw3demo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...