Jump to content

Kali Net Hunter & HackRF One

Recommended Posts

I was an original K

k starter supporter. I have a Nexus 7 running Kali Net Hunter. Anywho I see on the website for Net Hunter that it appears to be ready to roll for the HackRF. It's not. I have loaded the libhackrf and hackrf_info now sees my device, but I can't get startx to run. I'm thinking my gnuradio-companion is not properly installed. Anyone have this running properly in Net Hunter that can share how to get rolling?

Updated to add: apt-cache show hackrf-tools gave a description of the tools as a "transitional dummy package."

Error I get:

root@kali:~# gnuradio-companion

/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display

warnings.warn(str(e), _gtk.Warning)

/usr/lib/python2.7/dist-packages/gnuradio/grc/gui/Actions.py:30: GtkWarning: IA__gdk_keymap_get_for_display: assertion `GDK_IS_DISPLAY (display)' failed

_keymap = gtk.gdk.keymap_get_default()

/usr/lib/python2.7/dist-packages/gnuradio/grc/gui/Colors.py:24: GtkWarning: IA__gdk_screen_get_system_colormap: assertion `GDK_IS_SCREEN (screen)' failed

_COLORMAP = gtk.gdk.colormap_get_system() #create all of the colors

Traceback (most recent call last):

File "/usr/bin/gnuradio-companion", line 67, in <module>

from gnuradio.grc.python.Platform import Platform

File "/usr/lib/python2.7/dist-packages/gnuradio/grc/python/Platform.py", line 24, in <module>

from FlowGraph import FlowGraph as _FlowGraph

File "/usr/lib/python2.7/dist-packages/gnuradio/grc/python/FlowGraph.py", line 22, in <module>

from .. gui.FlowGraph import FlowGraph as _GUIFlowGraph

File "/usr/lib/python2.7/dist-packages/gnuradio/grc/gui/FlowGraph.py", line 22, in <module>

import Colors

File "/usr/lib/python2.7/dist-packages/gnuradio/grc/gui/Colors.py", line 27, in <module>

HIGHLIGHT_COLOR = get_color('#00FFFF')

File "/usr/lib/python2.7/dist-packages/gnuradio/grc/gui/Colors.py", line 25, in get_color

def get_color(color_code): return _COLORMAP.alloc_color(color_code, True, True)

AttributeError: 'NoneType' object has no attribute 'alloc_color'


Edited by Forgiven
Link to comment
Share on other sites

  • 1 month later...

Looks like the errors it's screaming is because there is now UI present.

Does GnuRadio run without the companion?

What errors are you getting when you try to start X?
Have you tried just doing a fresh install?

Link to comment
Share on other sites

  • 3 weeks later...

This may be an obvious question but you're doing this through a VNC right? That's the only way to get any gui or xsession in Nethunter. And we're still sharing our XSession with an Android session full of running apps on 2 gigs of ram. I try to stick with cli stuff in my Nex5. I tried Armitage once and even though it loaded, it wasn't worth using in that condition. I love NH cuz all the clii tools run excellent considering.... And it's a miracle i have MSF on my phone. Anything GUI related is just a party trick IMO on our Nex5/7/10 generation. I'm thinking of upgrading just for the extra gig of ram

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...