Jump to content

Proper method for installing ALFA AWUS036NEH drivers on Kali


vailixi
 Share

Recommended Posts

If you use an ALFA dongle and you have installed drivers on recent version of Kali please post your command line history segments that are relevant and any comments.

If you have never installed backports or the ALFA drivers on anything don't bother responding.

I can't get any of these packages to install on Kali Linux 1.1.0a 64 bit.

2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO won't build

backports-3.10.17-1 won't build

DPO_RT5572_LinuxSTA_2.6.1.3_20121022 won't build

I'm not sure if I need to install some other dependencies. Sorrry for not posting error messages.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Has anyone had any trouble getting this alfa to discover APs in Kali 2.0 when loaded as a VMWare* guest OS?

Neither wash nor airodump-ng discover APs. The issue seems to be one reported in a number of forums without any resolution.

airmon-ng sees the alfa.

i can set it into monitor mode with:

ifconfig wlan0mon down

iwconfig wlan0mon mode monitor

ifconfig wlan0mon up

but it then scans its lonely, empty scans until i stop them.

if anyone has experienced this and resolved it or has any ideas, i'd be grateful to hear them.

thank you.

*vmware fusion 7.1.2 with vmware tools updated in kali.

Link to comment
Share on other sites

ALFA devices are web supported on Kali 2.0. I'll assume you have the extensions pack installed. If not download.virtualbox.org/virtualbox/5.0.2/Oracle_VM_VirtualBox_Extension_Pack-5.0.2-102096.vbox-extpack

Then it should just be settings, install a USB device in the section named USB. Third tab from the bottum. Click the "+" and select the device.

I'll probably have to do a virtualbox install and see where this leads. I'll get to this a little later if you haven't got things up and running by then.

It should be something like the following as far as commands go. Won't do any good if you can't get the USB device to work in virtualbox none of the following will be of any value to you.

ifconfig wlan0 down

macchanger -r wlan0

ifconfig wlan0 up

airmon-ng start wlan0

Notice the newer version of aircrack will name the monitor interface wlan0mon instead of mon0 or something like that. Though I'm kinda confused as to why.

So then it's airodump-ng -w <filename> <interface>

Where <interface is the monitor mode interface>

If you are having signal strength issues.

ifconfig wlan0 down
iw reg set BO
ifconfig wlan0 up
iwconfig wlan0 channel 13
iwconfig wlan0 txpower 24

txpower can be up to 30 be depending on where you live there are FCC regulations and such.

ifconfig wlan0 up

Update: I tried getting the latest Kali build to install in Virtualbox. I'm getting some error about part of the install failing. Sorry I could not be more helpful with this.

Edited by vailixi
Link to comment
Share on other sites

Thanks for the tips. There's still something fishy going on with the alfa. I dug out a rtl8187 I had at my studio. That's working fine with everything in kali 2.0 as a vmware guest in os x 10.9.5. My pineapple MK5 is also interfacing correctly with my kali install.

Some other forums discuss circumstances under which older or modified drivers for the alfa had to be used under kali 1.0, and I guess they were included in some later distros as fallback options. Have any of you had to use those under kali 2.0?

Link to comment
Share on other sites

Yeah, I think are talking about compat wireless. https://wireless.wiki.kernel.org/welcome

There's also a ton of compatability information on the aircrack-ng site.

My devices have all been plug and play thus far. I haven't had to edit config files. Certainly haven't had to build a kernel. I'm satisfied with the kali 2.0 user experience.

Edited by vailixi
Link to comment
Share on other sites

The Alfa still isn't finding APs in monitor mode. In managed mode it can connect to APs and get on their networks, but airmon-ng/wash scans still turn up blanks.

I installed/uninstalled a couple iterations of Backports. That didn't change anything. This inability to function in monitor mode on virtualized installs seems a fairly common hit-or-miss problem with AWUS036NEH adapters.

This weekend I'll try setting kali up on a PC laptop to see if it's the adapter or the virtual environment causing issues.

Link to comment
Share on other sites

Not very experienced here, but I believe that when you monitor the answer is yes.

Wifi doesn't really do frequency hopping in the sense that as part of the protocol it predictably switches between channels (like, say, GSM does). I've also had a problem with monitoring once where the card wouldn't see anything specifically because it was monitoring the wrong channel.

Link to comment
Share on other sites

I meant frequency scanning. Sorry frequency hopping is something military radios do as a countermeasure to barrage jamming and monitoring. There's an algorithm that controls the hoping. So you have two or more radios hoping in sync and any radio that doesn't have the algorithm can't really communicate or intercept communications. I think it would be pretty sick of wireless routers could be made to do this with clients. It would be an added measure of security because you would have to have the WPA key then you would have to know the frequency hopping algorithm.

Maybe starting on a given channel.

airodump-ng wlan0mon --channel 6

I'm out of ideas after this.

Edited by vailixi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...