Jump to content

getting an 802.11AC USB NIC working


RS4
 Share

Recommended Posts

Someone else posted a similar topic but I didn't want to crown into theirs.

I have a ALFA AWUS036AC unit. The Mark V detects it fine, device 4

Protocol spec without prior Class and Subclass spec at line 17398

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub

Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

Bus 001 Device 004: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter

Bus 001 Device 005: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader



But where do I need to go from there? Any way to get drivers compiled? AC abilities would be nice to have.

Link to comment
Share on other sites

I'd done a wifi detect and it didn't through anything in the config file.

/etc/config/wireless:

root@Pineapple:~# cat /etc/config/wireless

config wifi-device radio0

option type mac80211

option channel 11

option hwmode 11ng

option macaddr 00:13:37:a5:46:e3

option htmode HT20

list ht_capab SHORT-GI-20

list ht_capab SHORT-GI-40

list ht_capab RX-STBC1

list ht_capab DSSS_CCK-40

config wifi-iface

option device radio0

option network lan

option mode ap

option ssid Pineapple5_46E3

option hidden 0

option encryption none

config wifi-iface

option device radio0

option network lan

option mode ap

option ssid Pineapple5_management

option encryption psk2+ccmp

option key 'pineapplesareyummy'

option disabled 1

config wifi-device radio1

option type mac80211

option channel 11

option hwmode 11g

option macaddr 00:13:37:97:19:76

config wifi-iface

option device radio1

option network lan

option mode sta

option ssid Pineapple5_1976

option hidden 0

option encryption none



and wifi:

root@Pineapple:~# wifi

command failed: Device or resource busy (-16)

wpa_supplicant_setup_vif(wlan1): Refusing to bridge sta mode interface

enable_mac80211(radio1): Failed to set up wpa_supplicant for interface wlan1

root@Pineapple:~#

just to make sure there's not something obvious I'm missing.

Link to comment
Share on other sites

tail'd version:

root@Pineapple:~# dmesg | tail

[ 46.240000] device eth0 entered promiscuous mode

[ 46.620000] eth0: link up (100Mbps/Full duplex)

[ 46.620000] br-lan: port 1(eth0) entered forwarding state

[ 46.630000] br-lan: port 1(eth0) entered forwarding state

[ 48.630000] br-lan: port 1(eth0) entered forwarding state

[ 51.770000] device wlan0 entered promiscuous mode

[ 51.990000] br-lan: port 2(wlan0) entered forwarding state

[ 51.990000] br-lan: port 2(wlan0) entered forwarding state

[ 53.990000] br-lan: port 2(wlan0) entered forwarding state

[ 398.350000] usb 1-1.2: new high-speed USB device number 5 using ehci-platform

root@Pineapple:~#

Full dmesg (long)

root@Pineapple:~# dmesg

[ 0.000000] Linux version 3.3.8 (sebkinne@buildtop) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #26 Mon Jan 12 23:39:08 CET 2015

[ 0.000000] MyLoader: sysp=97d936c9, boardp=61b798de, parts=6238a85e

[ 0.000000] bootconsole [early0] enabled

[ 0.000000] CPU revision is: 00019374 (MIPS 24Kc)

[ 0.000000] SoC: Atheros AR9330 rev 1

[ 0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz

[ 0.000000] Determined physical RAM map:

[ 0.000000] memory: 04000000 @ 00000000 (usable)

[ 0.000000] Initrd not found or empty - disabling initrd

[ 0.000000] Zone PFN ranges:

[ 0.000000] Normal 0x00000000 -> 0x00004000

[ 0.000000] Movable zone start PFN for each node

[ 0.000000] Early memory PFN ranges

[ 0.000000] 0: 0x00000000 -> 0x00004000

[ 0.000000] On node 0 totalpages: 16384

[ 0.000000] free_area_init_node: node 0, pgdat 802d8470, node_mem_map 81000000

[ 0.000000] Normal zone: 128 pages used for memmap

[ 0.000000] Normal zone: 0 pages reserved

[ 0.000000] Normal zone: 16256 pages, LIFO batch:3

[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768

[ 0.000000] pcpu-alloc: [0] 0

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256

[ 0.000000] Kernel command line: board=MK5 console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd

[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)

[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)

[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)

[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.

[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes

[ 0.000000] Writing ErrCtl register=00000000

[ 0.000000] Readback ErrCtl register=00000000

[ 0.000000] Memory: 61592k/65536k available (2124k kernel code, 3944k reserved, 406k data, 212k init, 0k highmem)

[ 0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1

[ 0.000000] NR_IRQS:51

[ 0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)

[ 0.080000] pid_max: default: 32768 minimum: 301

[ 0.080000] Mount-cache hash table entries: 512

[ 0.090000] NET: Registered protocol family 16

[ 0.090000] gpiochip_add: registered GPIOs 0 to 29 on device: ath79

[ 0.100000] MIPS: machine is MK5 V1.0

[ 0.350000] bio: create slab <bio-0> at 0

[ 0.360000] Switching to clocksource MIPS

[ 0.360000] NET: Registered protocol family 2

[ 0.370000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

[ 0.370000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)

[ 0.370000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)

[ 0.380000] TCP: Hash tables configured (established 2048 bind 2048)

[ 0.390000] TCP reno registered

[ 0.390000] UDP hash table entries: 256 (order: 0, 4096 bytes)

[ 0.400000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)

[ 0.400000] NET: Registered protocol family 1

[ 0.410000] PCI: CLS 0 bytes, default 32

[ 0.430000] squashfs: version 4.0 (2009/01/31) Phillip Lougher

[ 0.430000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.

[ 0.440000] msgmni has been set to 120

[ 0.440000] io scheduler noop registered

[ 0.450000] io scheduler deadline registered (default)

[ 0.450000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled

[ 0.460000] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART

[ 0.470000] console [ttyATH0] enabled, bootconsole disabled

[ 0.480000] m25p80 spi0.0: found w25q128, expected m25p80

[ 0.480000] m25p80 spi0.0: w25q128 (16384 Kbytes)

[ 0.490000] 5 tp-link partitions found on MTD device spi0.0

[ 0.490000] Creating 5 MTD partitions on "spi0.0":

[ 0.500000] 0x000000000000-0x000000020000 : "u-boot"

[ 0.510000] 0x000000020000-0x00000010272c : "kernel"

[ 0.510000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only

[ 0.520000] 0x00000010272c-0x000000ff0000 : "rootfs"

[ 0.530000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only

[ 0.540000] mtd: partition "rootfs" set to be root filesystem

[ 0.550000] mtd: partition "rootfs_data" created automatically, ofs=CC0000, len=330000

[ 0.550000] 0x000000cc0000-0x000000ff0000 : "rootfs_data"

[ 0.560000] 0x000000ff0000-0x000001000000 : "art"

[ 0.570000] 0x000000020000-0x000000ff0000 : "firmware"

[ 0.590000] ag71xx_mdio: probed

[ 0.590000] eth0: Atheros AG71xx at 0xb9000000, irq 4

[ 1.150000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]

[ 1.160000] TCP cubic registered

[ 1.160000] NET: Registered protocol family 17

[ 1.160000] Bridge firewalling registered

[ 1.170000] 8021q: 802.1Q VLAN Support v1.8

[ 1.180000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.

[ 1.190000] Freeing unused kernel memory: 212k freed

[ 3.520000] Registered led device: mk5:red:wlan1

[ 3.520000] Registered led device: mk5:blue:wlan0

[ 3.520000] Registered led device: mk5:amber:lan

[ 6.150000] eth0: link up (100Mbps/Full duplex)

[ 6.850000] JFFS2 notice: (421) jffs2_build_xattr_subsystem: complete building xattr subsystem, 4 of xdatum (1 unchecked, 3 orphan) and 30 of xref (0 dead, 15 orphan) found.

[ 7.820000] SCSI subsystem initialized

[ 8.120000] usbcore: registered new interface driver usbfs

[ 8.120000] usbcore: registered new interface driver hub

[ 8.130000] usbcore: registered new device driver usb

[ 8.680000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver

[ 8.680000] ehci-platform ehci-platform: Generic Platform EHCI Controller

[ 8.690000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1

[ 8.730000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000

[ 8.750000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00

[ 8.750000] hub 1-0:1.0: USB hub found

[ 8.750000] hub 1-0:1.0: 1 port detected

[ 8.860000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

[ 8.990000] uhci_hcd: USB Universal Host Controller Interface driver

[ 9.110000] Initializing USB Mass Storage driver...

[ 9.110000] usbcore: registered new interface driver usb-storage

[ 9.120000] USB Mass Storage support registered.

[ 9.220000] usb 1-1: new high-speed USB device number 2 using ehci-platform

[ 9.370000] hub 1-1:1.0: USB hub found

[ 9.370000] hub 1-1:1.0: 4 ports detected

[ 9.650000] usb 1-1.1: new high-speed USB device number 3 using ehci-platform

[ 9.890000] usb 1-1.4: new high-speed USB device number 4 using ehci-platform

[ 10.020000] scsi0 : usb-storage 1-1.4:1.0

[ 11.020000] scsi 0:0:0:0: Direct-Access Multi Flash Reader 1.00 PQ: 0 ANSI: 0

[ 11.580000] sd 0:0:0:0: [sda] 7806976 512-byte logical blocks: (3.99 GB/3.72 GiB)

[ 11.580000] sd 0:0:0:0: [sda] Write Protect is off

[ 11.590000] sd 0:0:0:0: [sda] Mode Sense: 03 00 00 00

[ 11.590000] sd 0:0:0:0: [sda] No Caching mode page present

[ 11.590000] sd 0:0:0:0: [sda] Assuming drive cache: write through

[ 11.600000] sd 0:0:0:0: [sda] No Caching mode page present

[ 11.610000] sd 0:0:0:0: [sda] Assuming drive cache: write through

[ 11.610000] sda: sda1

[ 11.620000] sd 0:0:0:0: [sda] No Caching mode page present

[ 11.630000] sd 0:0:0:0: [sda] Assuming drive cache: write through

[ 11.630000] sd 0:0:0:0: [sda] Attached SCSI removable disk

[ 29.540000] eth0: link down

[ 30.530000] Loading modules backported from Linux version master-2014-01-23-0-g62c147d

[ 30.530000] Backport generated by backports.git backports-20140124-0-g1256d3e

[ 30.580000] cfg80211: Calling CRDA to update world regulatory domain

[ 30.580000] cfg80211: World regulatory domain updated:

[ 30.590000] cfg80211: DFS Master region: unset

[ 30.590000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)

[ 30.600000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

[ 30.610000] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

[ 30.610000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)

[ 30.620000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 2000 mBm)

[ 30.630000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 2000 mBm)

[ 30.640000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm)

[ 32.200000] usbcore: registered new interface driver rt73usb

[ 32.260000] ath: EEPROM regdomain: 0x0

[ 32.260000] ath: EEPROM indicates default country code should be used

[ 32.260000] ath: doing EEPROM country->regdmn map search

[ 32.260000] ath: country maps to regdmn code: 0x3a

[ 32.260000] ath: Country alpha2 being used: US

[ 32.260000] ath: Regpair used: 0x3a

[ 32.270000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'

[ 32.270000] Registered led device: ath9k-phy0

[ 32.270000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2

[ 32.280000] cfg80211: Calling CRDA for country: US

[ 32.280000] cfg80211: Regulatory domain changed to country: US

[ 32.290000] cfg80211: DFS Master region: FCC

[ 32.290000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)

[ 32.300000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)

[ 32.310000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 1700 mBm)

[ 32.320000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (300 mBi, 2400 mBm)

[ 32.320000] cfg80211: (5490000 KHz - 5600000 KHz @ 80000 KHz), (300 mBi, 2400 mBm)

[ 32.330000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2400 mBm)

[ 32.340000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 3000 mBm)

[ 32.350000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm)

[ 32.640000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'

[ 32.650000] ieee80211 phy1: hwaddr 00:13:37:97:19:76, RTL8187vB (default) V1 + rtl8225z2, rfkill mask 2

[ 32.670000] rtl8187: Customer ID is 0x46

[ 32.670000] Registered led device: rtl8187-phy1::radio

[ 32.670000] Registered led device: rtl8187-phy1::tx

[ 32.670000] Registered led device: rtl8187-phy1::rx

[ 32.680000] rtl8187: wireless switch is on

[ 32.680000] usbcore: registered new interface driver rtl8187

[ 32.770000] Button Hotplug driver version 0.4.1

[ 32.990000] RPC: Registered named UNIX socket transport module.

[ 32.990000] RPC: Registered udp transport module.

[ 32.990000] RPC: Registered tcp transport module.

[ 33.000000] RPC: Registered tcp NFSv4.1 backchannel transport module.

[ 33.320000] PPP generic driver version 2.4.2

[ 33.360000] usbcore: registered new interface driver rt2800usb

[ 33.490000] tun: Universal TUN/TAP device driver, 1.6

[ 33.490000] tun: © 1999-2004 Max Krasnyansky <maxk@qualcomm.com>

[ 33.840000] ip_tables: © 2000-2006 Netfilter Core Team

[ 34.070000] NET: Registered protocol family 24

[ 34.220000] nf_conntrack version 0.5.0 (965 buckets, 3860 max)

[ 34.920000] xt_time: kernel timezone is -0000

[ 35.450000] usbcore: registered new interface driver ath9k_htc

[ 35.490000] usbcore: registered new interface driver cdc_acm

[ 35.490000] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

[ 35.720000] usbcore: registered new interface driver usbserial

[ 35.720000] USB Serial support registered for generic

[ 35.730000] usbcore: registered new interface driver usbserial_generic

[ 35.730000] usbserial: USB Serial Driver core

[ 35.870000] usbcore: registered new interface driver asix

[ 35.950000] usbcore: registered new interface driver cdc_ether

[ 36.190000] Error: Driver 'gpio-keys-polled' is already registered, aborting...

[ 36.290000] usbcore: registered new interface driver rndis_host

[ 36.410000] sd 0:0:0:0: Attached scsi generic sg0 type 0

[ 36.430000] USB Serial support registered for GSM modem (1-port)

[ 36.430000] usbcore: registered new interface driver option

[ 36.440000] option: v0.7.2:USB Driver for GSM modems

[ 36.460000] USB Serial support registered for pl2303

[ 36.460000] usbcore: registered new interface driver pl2303

[ 36.470000] pl2303: Prolific PL2303 USB to serial adaptor driver

[ 46.240000] device eth0 entered promiscuous mode

[ 46.620000] eth0: link up (100Mbps/Full duplex)

[ 46.620000] br-lan: port 1(eth0) entered forwarding state

[ 46.630000] br-lan: port 1(eth0) entered forwarding state

[ 48.630000] br-lan: port 1(eth0) entered forwarding state

[ 51.770000] device wlan0 entered promiscuous mode

[ 51.990000] br-lan: port 2(wlan0) entered forwarding state

[ 51.990000] br-lan: port 2(wlan0) entered forwarding state

[ 53.990000] br-lan: port 2(wlan0) entered forwarding state

[ 398.350000] usb 1-1.2: new high-speed USB device number 5 using ehci-platform

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...