Jump to content

NoDogSplash with no Internet and Autostart question


Recommended Posts

After some more testing i see that the captive portal notification will pop up on Android tablets (Nexus 9 on 5.0, Samsung Tab 4 on 4.4.2) and not on Android mobiles (Galaxy S4 on 4.4.2). Although when surfing the web all traffic gets redirected. (even clients3.google.com/generate_204). Only way to pop the browser on my galaxy S4 is "address=/#/1.1.1.1" along with nodogsplash. I will try to replicate the iptables nodogsplash creates. Sounds easy..

Sorry but i dont have any others devices for testing :P

NOTE: I deleted the previous post until i find something more stable!!!

Edited by KiatoGS
Link to post
Share on other sites

Got it. I KNEW it was something with the landing page ;-)

The splash thinga somehow has a problem with php, so i edited the uhttpd (i used a mk 4 for testing, didn´t want to screw up my working mk5, i guess this will work on the mk 5 using nginx config as well, will test the next days) and told him the *only* landing page is my splash.html (i created a splash.html inside /www). i removed the index.php and also all the other alternative landing pages in the web server config file. so in the splash.html i did not used any php. i also noticed this pseudo browser popping up on ios devices seems to have a problem not only with php but also with images located in other directories and also images which are referenced just as their name directly. the solution was to embed the image like this: img src="http://172.16.42.1/bla.jpg" width="505" height="562" border="0"

That worked for me. dnsspoof was not necessary. What WAS necessary was your nat rules (i used the 80 and also the 53 udp+tcp - have to try if the 80 only is enough - was too lazy ;-)) Also what was essential is the modification with dnsmasq so the pineapple itsself thinks everything is located outside his scope.

So - WOW - i guess we have found a way

a) splashing without nodogsplash and

b) without internet connection ;-)

Edited by johnsteiner
Link to post
Share on other sites

...tested it with mk5. works without nodogsplash. even more stable and top likes it also. now the most hungry process is pinejector. be aware, if you remove index.php out of nginx.conf, you have to explicitly open http://172.16.42.1:1471/index.php when you want to access admin ui. the other way (i am testing this now) is to leave index.php in place in nginx.conf (in parallel with splash.html or whatever your splash is) and remove index.php from within /www. don´t forget to /etc/init.d/nginx restart every time you touch this file.

Edited by johnsteiner
Link to post
Share on other sites

Yeap, Nodogsplash can't handle php :(.

So here is what i did! (using a mk4 after a clean flash)

1) save the default iptables configuration

(iptables-save > default_iptables.conf)

2) edit nodogsplash.conf to include only the gateway and users-to-router rules (allowing also 1471)

3) run nodogsplash and save it's iptables configuration (iptables-save > portal_iptables.conf)

4) stop nodogsplash

5) edit your dnsmasq for the 1.1.1.1 and run it.

6) change your web server port to 2050 and restart it.

7) aply the portal iptables (iptables-restore portal_iptables.conf)

8)You should be good to go ;)

I have made a script (because i love scipts ;) ) that does all this. I will post when i get back to my pineapple ;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...