Jump to content

wp5.sh and Armitage?


xrad
 Share

Recommended Posts

I seem to have this problem no matter what machine I run it on.

In Kali after I run the wp5.sh, my ability to use Armitage gets fragged and Armitage can not connect to metasploit. I get this:

Could not connect to database.

Kali Linux users, try:

service postgresql start

service metasploit start

service metasploit stop

FATAL; no pg_hba.conf entry for host "192.168.0.143", user "msf3", database "msf3", SSL off

That is from my vm, on my netbook it says 172.16.42.42

Trying to start and stop the metasploit service does not correct the problem, Does doing ICS confuse the loopback from Armitage to msf?

Is there a way to maybe change my interfaces file in /etc/network or the network manager config file in /etc/NetworkManager, to fix this?

Edit: Maybe I need to edit the pg_hba.conf file to correct

Edited by xrad
Link to comment
Share on other sites

I have run into this problem before I believe this subject is more suited for the metasploit forums

To resolved this problem, you can try this.

first you have find out your pg_hba.conf and write :

local all all md5

after that restart pg server:

postgresql restart

or

sudo /etc/init.d/postgresql restart

I found that with one search in google

Please search first

Edited by m40295
Link to comment
Share on other sites

You can look in /etc/postgresql/9.1/main/pg_hba.conf to see what entries are in there (grep -v '^#' /etc/postgresql/9.1/main/pg_hba.conf). You can also look at wp5.sh (do you have a link?) to see what it might have done to affect the postgress settings. I haven't seen or used wp5.sh.

Link to comment
Share on other sites

m40295..and fringes.

Thank you both very much for the help.....I apologize for asking in the wrong place...I actually wasn't sure where to ask. Everything works fine until I run wp5.sh that I downloaded from:

http://wiki.wifipineapple.com/#!ics.md

So I thought this would be the correct place to ask.

I tried your suggestions today along with some other settings last night that I was reading from

http://www.postgresql.org/docs/9.3/static/auth-pg-hba-conf.html

I now see the mistake I was making trying to fix the problem.

Yay……its working

I do appreciate the help, and Thanks again.

Mods feel free to move the thread to the appropriate place.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...