Jump to content

wlan1 not working


hll1234
 Share

Recommended Posts

I sat and left my mark v on after using. Came back an hour later, put wlan1 in monitor mode and ran airodump. Nothing.

I cannot detect or connect to aps with wlan1. wlan0 works normally.

Getting "phy1: RF Calibration Failed! a66" with dmesg. Any ideas on this? I'm worried this may be hardware failure but admit I don't know enough to really make that diagnosis.

I've tried restoring factory defaults and have tried flashing the latest firmware.

root@Pineapple:~# iwconfig
lo        no wireless extensions.

wlan0mon  IEEE 802.11bgn  Mode:Monitor  Tx-Power=18 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off
          
wlan1     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
wlan0-1   IEEE 802.11bgn  Mode:Master  Tx-Power=18 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off
          
eth0      no wireless extensions.

br-lan    no wireless extensions.

root@Pineapple:~# lsusb
Protocol spec without prior Class and Subclass spec at line 17398
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
root@Pineapple:~# lsmod | grep rtl
rtl8187                46576  0 
rtl8180                25168  0 
mac80211              318192  7 ath9k_htc,rtl8187,ath9k,rtl8180,rt2800lib,rt2x00usb,rt2x00lib
usbcore                99168 20 pl2303,option,rndis_host,usb_wwan,cdc_ether,asix,usb_storage,usbserial,usbnet,cdc_acm,ath9k_htc,uhci_hcd,ohci_hcd,ledtrig_usbdev,ehci_hcd,rt2800usb,rtl8187,rt73usb,rt2x00usb
eeprom_93cx6            1632  2 rtl8187,rtl8180
cfg80211              184064  7 ath9k_htc,rtl8187,ath9k,rtl8180,ath,rt2x00lib,mac80211
compat                  9472  9 ath9k_htc,rt2800usb,rtl8187,ath9k,rtl8180,rt73usb,ath9k_common,mac80211,cfg80211

root@Pineapple:~# ifconfig wlan1
wlan1     Link encap:Ethernet  HWaddr 00:13:37:97:10:3D  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
root@Pineapple:~# dmesg |grep phy1
[   14.730000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   14.730000] ieee80211 phy1: hwaddr 00:13:37:97:10:3d, RTL8187vB (default) V1 + rtl8225, rfkill mask 2
[   14.760000] Registered led device: rtl8187-phy1::radio
[   14.760000] Registered led device: rtl8187-phy1::tx
[   14.760000] Registered led device: rtl8187-phy1::rx
[   38.880000] ieee80211 phy1: RF Calibration Failed! a66
[  180.000000] ieee80211 phy1: RF Calibration Failed! a66
[  205.310000] ieee80211 phy1: RF Calibration Failed! a66
[  648.440000] ieee80211 phy1: RF Calibration Failed! a66
root@Pineapple:~# dmesg |grep phy0
[   10.690000] ath: phy0: Enable LNA combining
[   10.710000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   10.710000] Registered led device: ath9k-phy0
[   10.710000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...