Jump to content

USB Rubber Ducky wont create a report file.


Recommended Posts

Hi, I have just recently bought the USB rubber ducky and everything was going perfect until I couldn't find the report file. I have been using the payload generator at ducktoolkit.com and everything that I entered in the text fields while creating the payload was correct it still wont create a report file. I have tried saving the report to the target machine, emailing the report to a gmail account and saving the files to a USB but still no report file.

I really want to try fix this so if anybody has any ideas let me know!


Link to comment
Share on other sites

Well at what point is it failing? The ducky isn't doing anything magic - it is just a keyboard typing faster than a human can.

I suggest you work out how to do the report by hand and find out what needs to be executed on the keyboard. Unless you provide a fail case or more information nobody can really help you...

Link to comment
Share on other sites

Well post the command that isn't working as expected, your OS and other pertinent information and I'll try and help :)

Are you on Windows? Are you familiar with PowerShell?

I think the root cause is that the duck / site are aimed more at "script kiddies" and assume the user doesn't want to know / understand what is going on and how the functionality works.

A better approach is to devise a script that works for you and then port it into a duck script rather that using a site to auto-magically generate a script... The unreadable / hard to maintain scripts are the reason that I don't use the duck anymore (along with accidentally breaking my duck when drunk! :) )

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...