Jump to content

802.11n with AWUS036NEH


nemesis_00
 Share

Recommended Posts

My wifi is on 802.11n, with pineapple i can't see it beacuse i've read that RTL8187 doesn't support it, so i connected AWUS036NEH, which support 802.11n, and searched for APs with wps infusion with wlan2 (AWUS036NEH) but I can't still find it, what am I doing wrong?

(firmware and infusions updated, using power adaptor not battery)

Thanks

Link to comment
Share on other sites

I've had some routers that had wps enabled, but didn't show in a wash output. If you know for sure that wps is a constant active ( not enabled only buy physical push button ) try ssh'ing to the pineapple and run reaver from commandline with the target mac. And see if it starts attacking the router as expected. Also if just for visibilty concerns, run wash for a while through ssh and see if your ap comes up eventually as wps enabled

Link to comment
Share on other sites

weird stuff going on...

airmon-ng start wlan2
//awus036neh is in monitor mode

airodump-ng mon0
//lots of newtwork, even mine :D

wash -i mon0
//nothing but bad fcs

reaver ...
//no results (even trying the right pin) because i discovered that the router has a push button, inside router administration webpage

so my main concern (awus036neh doesn't work) is gone

last question is: what's wrong with wash?

from terminal just doesn't work, from infusion can't see existing networks

Link to comment
Share on other sites

After you put the device into monitor mode, bring down the interface. In this case wlan2. ifconfig wlan2 down. The drivers are finniky with having a mon and coresponding wlan interface both up at the same time

But a personal favorite, if you are using the ne 2.1 firmware, the aircrack packages are updated. So you can make use of airmon-zc. Which will take care of bringing down the interface for you.

So airmon-zc start wlan2.

The monitor interface naming syntax is different with airmon-zc. The result is itbeing wlan2mon after in monitormode.

And as for wash, there is a switch to ignore bad fc.

wash -C I think? so try all that and report back

Link to comment
Share on other sites

ok, so that's what i did

airmon-zc start wlan2
//ok

airodump-ng wlan2mon
//all networks are dispalyed

wash -i wlan2mon --ignore-fcs
//nothing displayed, if I include fcs it's all bad fcs

reaver doesn't work but i think because of the router which has the push button function

I've tried wash with wlan0 and wlan1 (enabling monitor and disabling interface with airmon-zc) but it still doesn't work, all bad fcs

Link to comment
Share on other sites

I also would like to mention, that if you chose to install reaver to the sd card, for some reason not all required directories / symlinks are made, and will cause reaver / wash to not function properly either. So either make the proper symlinks or just install to internal storage. I think you need to mkdir /etc/reaver. Then ln -s the reaver.db Let me check my script and ill post back.

Edited by datahead
Link to comment
Share on other sites

here is my proper openwrt reaver /sd install chain.

mkdir /etc/reaver

opkg update

opkg -d sd install reaver

ln -s /sd/etc/reaver/reaver.db /etc/reaver/

ln -s /sd/usr/bin/reaver /usr/bin/

ln -s /sd/usr/bin/wash /usr/bin

ln -s /sd/usr/lib/opkg/info/reaver.control /usr/lib/opkg/info/

ln -s /sd/usr/lib/opkg/info/reaver.list /usr/lib/opkg/info/

Not sure why that directory & file isn't created or symlinked during the normal /sd install process for reaver / wash, but I just had to mkdir and symlink it myself. And it fixed any problems with wash via cli and the wps infusion that I was having. But also if you choose not to have it install on the sd card, but install it to the pineapples internal storage, all works fine also.

I'm sure some of those symlinks for opkg aren't needed l, but I feel better just symlinking all myself if they somehow aren't during the install process for reaver.

Edited by datahead
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...