Jump to content

MacBook can't connect on management wpa2


DAC
 Share

Recommended Posts

Hi

I've got my PinappleV up and running (brilliant piece of kit :-)), I have connected Radio1 to the internet via my home AP and can connect to the open AP on the PineApple (in my case the one named Pineapple5_3FA1 on Radio0).

However when I try to connect to the WPA2 AP (also on Radio0) my MacBook refuses to connect and reports "connection failed"

When I plug in the USB ALFA (configured as Radio2, with the same config as the Radio0) my MacBook happily connects via WPA2.

Below is my wireless config.

Any idea what or where I'm going wrong? Ideally I'd like to connect using WPA2 to the Radio0 on the LAN for management.

Thanks

DAC

Backup [2014-12-28 21-07-20]
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:a5:3f:a1'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_3FA1'
option hidden '0'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_mngment'
option key 'password'
option disabled '0'
option hidden '0'
option encryption 'psk2+tkip'
config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option macaddr '00:13:37:97:11:c8'
option channel '4'
option disabled '0'
config wifi-iface
option device 'radio1'
option mode 'sta'
option hidden '0'
option network 'wan'
option ssid 'MyHomeAP'
option key 'myAPPassword'
option encryption 'psk2+tkip'
config wifi-device 'radio2'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:c0:ca:85:27:92'
option htmode 'HT20'
list ht_capab 'GF'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
option disabled '0'
config wifi-iface
option device 'radio2'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple_USB'
option key 'mypassword'
option disable '0'
option hidden '0'
option encryption 'psk2+psk'
Link to comment
Share on other sites

DAC,

Considering you are using OS X , what version?

Apple has a fancy way of doing things and is forcing the 192.168.1.X subnet rather than the 172.16.42.X for sharing ( assuming this is what you are trying to do)

What is the contents of /etc/bootpd.plist and /Library/Preferences/SystemConfiguration/com.apple.nat.plist?

Link to comment
Share on other sites

Hi

I'm using 10.9.5.

I managed to get this working by adding another WPA2 interface to the wifi device (which my Mac connected to) and then hiding the original WPA2!

I was not trying to share, just connect to the pineappleV over an encrypted channel and not in the clear.

A fudge, but it's working now (I'll try and work out why when I have some more time).

Thanks

DAC

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...