Jump to content

Wireless Interfaces Problem


Skye
 Share

Recommended Posts

Hi,

I've just received my WiFi Pineapple and have been running into some issues, of which I've partially fixed by using the manual and this forum.

But I have been noticing some odd issues with the wireless interfaces in the web management interface. They either don't enable (start up) or stay up. For instance I have successfully connected to a wireless router on wlan1 (Which is the only interface in the Network tab), but the connection information states I'm not connected. Furthermore the network tab will often show that wlan1 is not enabled (Even though there is an active connection) and upon enabling the interface it will swap wlan0 to enabled.

I can still download infusions and get an active internet connection whilst wlan1 states it's not enabled. I find that rather strange. Another thing that should be noted is that before doing the firmware update I had a wireless connection to the web interface for initial setup however this tends to disappear or not be available at boot.

Just to list some questions relating to this post:

Is this a problem with the newest firmware? Can this be fixed?

Why doesn't the wireless access point/connection start at boot? As I don't full understand this part of the unit, do I have to change something to make it active?

Thanks,

-Skye

Link to comment
Share on other sites

  • 2 weeks later...

wlan1 is never enabled at boot, there is nothing "strange" about it many systems boot with one of mult interfaces down. WLAN1 is used for injection since the hardware bug identified in the MKV for client connectivity you should add a USB Alfa for WLAN2 and that, too will be disabled at boot. All of that can be changed via dip switch commands, etc. but I don't think it has anything to do with the firmware version you are using. My strong suggestion is to search the forum and do a bit more reading before freaking out too badly about what may be normal behavior and will help you learn (why we're here, right) pineapple usage a little more.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...