Jump to content

Access Point change with new firmware how to disable


hk887
 Share

Recommended Posts

Hi,

After I updated to the new firmware there is an open ap and a secure ap option. Is there any way to disable the open ap if I only want the secure ap to broadcast? I know you can hide the open ap ssid but I don't want it to show up at all.

The only way to I got it to go away was using the wifi management infusion, but If it do that it causes problems when I try to use my usb wifi adapter in client mode. My usb adapter keeps getting disabled every time I try to connect to an ap.

I just want to broadcast my secure ap.

Thanks

Link to comment
Share on other sites

I already tried Wifi Manager, it seems to cause problems with the network infusion. After I removed the config and apply the change it still broadcasts the hidden open ap. So I rebooted the pineapple, and once it boots up it displays the default ssid the pineapple comes with. So it just overwrites the deleted config with the default.

I would really love to see the disable check box option that is available for the secure ap. It seems it forces you to use the open ap.

Link to comment
Share on other sites

If I edit the open ap config in wifi management I can change it to be secure, however my usb adapater (Wlan 2 gets disabled everytime try to do anything with it if I use wifi manager) If I go into network to change the mac address on wlan2 it says it changed then just has a blank address in the slot, then it gets disabled. I have to unplug and replug my usb adapter to see it again.

If I try to connect to an ap in client mode with my usb adapter it gets disabled.

So I removed wifi manager and reset wireless settings.

When I go into network to change mac address on my usb adapater it works just fine, when I try to connect to an ap with my usb adapter it works just fine.

So wifi management infusion is conflicting with the network infusion.

Just using the network infusion I can do everything I want to except remove the open ap that starts by default.

Link to comment
Share on other sites

what about

ifconfig wlan0 down?

or

ifconfig wlan0-1 down

the new firmware added a virtual device branched from wlan0, thus 2 AP's ( on wlan0 and wlan0-1 )

one of those is the open pineapple network, the other is the wpa secured one. i'd imagine the open one is on wlan0. try bringing that interface down and see if that will do the trick, and if so, set it to a boot mode dip switch. as i havent tested this yet

Link to comment
Share on other sites

datahead is right, I was doing exactly that until I decided to secure them both. ifconfig wlan0 down will disable the unsecured SSID. I was kind of lazy and just added the command to /etc/rc.local to disable at boot. if you ever need it, you can just run `ifconfig wlan0 up` and it will be active until your next reboot.

I decided to secure them both with WPA2 from the command line. so, here's how mine looks now(also added freeradius):

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option macaddr '00:13:37:a5:39:34'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option channel '1'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'Pineapple5_3934'
        option key 'SharedSecret'
        option server '172.16.42.1'
        option port '1812'
        option encryption 'wpa2'
        option hidden '0'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'wpa2'
        option disabled '0'
        option encryption 'wpa2'
        option key 'SharedSecret'
        option server '172.16.42.1'
        option port '1812'

is there some reason for the unsecured network? I would just try to remove it, but I'm affraid something depends on it being there..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...