Jump to content

Troubleshooting DNS issues (not dnsspoof)


roboshed
 Share

Recommended Posts

I'm running MK5 firmware 1.2.0

When I ssh onto the box and run "ping google.com", it fails, but "ping 74.125.225.129" it works fine, same with traceroute. This also means that clients that connect via Karma have internet issues.

I have the pineapple connected through ethernet to my windows laptop, which is connected to internet over wifi, following this guide:

root@Pineapple:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 172.16.42.42 0.0.0.0 UG 0 0 0 br-lan
172.16.42.0 * 255.255.255.0 U 0 0 0 br-lan
How would I go about debugging this?
Link to comment
Share on other sites

I'm sure you want to update to Firmware 2.0.4 ?

If you can ping an IP but not a hostname -> check your DNS Settings.

Thanks for responding, I actually just updated to firmware 2.0.4 and am still seeing the issue.

Should I be checking DNS settings on the pineapple or my laptop? As far as I can tell I have the same settings from the tutorial - IPv4 adapter is set to use 8.8.8.8 (or 4.4.4.4 as alternate)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...