Jump to content

Cannot Connect as Client to WPA2 APs


highpass
 Share

Recommended Posts

Hello,

I've been using the pineapple's client mode quite happily on my routers in location 1, but am having no luck with any in location 2 - something I must assume is due to encryption types. I had read a few topics here regarding the issue (in particular one from 2013 mentioning a config alteration) but haven't had any luck.

If someone could point me to existing topics on the matter or tell me what logs to post here for diagnosis that'd be great.

Cheers,

HP

Link to comment
Share on other sites

Just to add (and I would edit the initial post if I were allowed), I have tried the following:

Restart Pineapple

Disable all infusions

Enable/disable wlan1

Reset all wireless configs

Reboot without SD card

Change }elseif($ap->security->WPA2 != null && $ap->security->WPA2 != null){ to }elseif($ap->security->WPA != null && $ap->security->WPA2 != null){ in functions.php

Crossing fingers/toes/praying

Wlan0 is set to access point/LAN

Wlan1 is set to client mode/WAN

Result of ssh 'wifi' command: command failed: Device or resource busy (-16)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...