Jump to content

Pineapple Plug: Manually connecting two Pineapple's?


neep3r
 Share

Recommended Posts

I have two MKV Pineapples and the new Pineapple Plug that I'd like to configure to work together. I set the second Wifi Pineapple's IP to 172.16.42.2 (in /etc/config/network) while keeping the first Wifi Pineapple's default, at 42.1. I then connected both Pineapples to the Wifi Pineapple Plug and booted them up. At this point I'm not sure what to do, nor do I know for sure if the Plug setup is working properly.

I'm guessing it will be much easier to run two Pineapples together in future firmware updates but if anyone has experience working with two Pineapples I'd love a push in the right direction, or where to find relevant instructions/resources.

Thanks!

Link to comment
Share on other sites

You also need to set the gateway to 172.16.42.1 on the second pineapple with the IP address of 172.16.42.2.

There will be a firmware update that takes advantage of the pineplug giving it its full functionality in the near future I assume.

Link to comment
Share on other sites

You also need to set the gateway to 172.16.42.1 on the second pineapple with the IP address of 172.16.42.2.

There will be a firmware update that takes advantage of the pineplug giving it its full functionality in the near future I assume.

Thanks newbi3, you rock! Yeah it looks like this will be solved with a flick of a dip switch. Looking forward to the next firmware :D

Link to comment
Share on other sites

Thanks newbi3, you rock! Yeah it looks like this will be solved with a flick of a dip switch. Looking forward to the next firmware :D

I'm not sure if its the next firmware release or the one after that but I'd imagine it will be soon. I'm not a firmware dev I just make infusions

Link to comment
Share on other sites

Here are my Pineapple's /etc/config/network settings now:

Pineapple #1:

config interface lan

option ifname eth0

option type bridge

option proto static

option ipaddr 172.16.42.1

option netmask 255.255.255.0

option gateway 172.16.42.42

option dns 8.8.8.8

Pineapple #2:

config interface lan

option ifname eth0

option type bridge

option proto static

option ipaddr 172.16.42.2

option netmask 255.255.255.0

option gateway 172.16.42.1

option dns 8.8.8.8

I booted both up in the plug but don't see a network connection or the ability to utilize the second Pineapple's wireless cards. Are there additional steps I am missing?

Thanks again :)

Link to comment
Share on other sites

Can you ssh into pineapple 2 (172.16.42.2) and ping google.com and see if you get any replies.

Remember the first pineapple will have to have an internet connection

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   1 member

×
×
  • Create New...