Jump to content

BRICKED.Md5sum. Solid red & green light. No web interface


Archimac
 Share

Recommended Posts

Hi everyone at Hack5 and pineapple users. I'm a novice and first time user of a pineapple V and am hoping for some help with a technical problem.

Firstly a bought the pineapple via ebay UK as a "new" device (It was around the same price without import costs as buying from Hack5 in the US but also quicker shipped...that was my first mistake) Pineapple arrived with the sd card inserted and clearly had been fired up before so I am unsure of its history.

It boots after some initial flashes to SOLID RED AND GREEN LIGHT. It is also not accessible from the web interface at all so can't reset via there.

I initially thought it may nave been a bad sd card which I have read of on the forum so tried another card and flashed the latest update to it from the downloads page at Hack5. Still nothing and still no boot past red and green lights.

I read that the red light means that the firmware has a corrupted md5sum but the problem I have is that I can't communicate with the pineapple at all to try a firmware flash

I have tried to SCP the pineapple with Ethernet bia the static ip 192.168.1.2 etc but it doesn't seem to work ...although I may well not be doing this correctly as I am definitely a novice user -could anyone help or talk me through how to do this?

Might I nead a serial UART to get directly to the board and flash it that way(???)

I have tried to reset the pineapple with the dip switches (dip 2 + 3 in the down position) to reset system defaults but still nothing but solid red and green light boot.

Could anyone please help me with what I need to do with it -I'm afraid my technically knowledge is low but am willing to learn and know how to fix the issues ...if I buy a fresh pineapple I simply don't want this to happen again and it still be beyond my capabilities to fix :/

Thanks to the forum

Please comment if you can help.

Cheers. Archimac

Link to comment
Share on other sites

Did you tried this here --> https://wifipineapple.com/?flashing ??

Unbricking a bricked WiFi Pineapple MKV

Bricked your WiFi Pineapple MKV? Unbricking is easy and doesn't require any extra hardware!

  • Download the special factory image. This image is the WiFi Pineapple MKV's 1.2.0 firmware, packaged differently to allow unbricking. Please verify it's md5 checksum to be 167b1533b9dd5c49f7107413fb960bfa.
  • Power off your WiFi Pineapple MKV and set the DIP switches to up, up, up, up, down (from left to right).
  • Connect to your WiFi Pineapple MKV via ethernet and set your network interface to a static IP of 192.168.1.2
  • Boot up the WiFi Pineapple MKV. After around five seconds, you can navigate to http://192.168.1.1
  • Upload the factory-1.2.0.bin file through the interface. Wait for it to complete.
  • Set all the DIP switches back to the default configuration up, up, up, up, up (from left to right).
  • Make sure the SD card is inserted and powercycle the WiFi Pineapple MKV. Your device will now boot the 1.2.0 firmware. Please wait patiently and refer to the first boot instructions in your WiFi Pineapple MKV instructions. You may skip any information relating to the stager.
  • You are done. Enjoy your freshly flashed WiFi Pineapple MKV!

No need to use SCP

Edited by BeNe
Link to comment
Share on other sites

Hi beNe

Thanks for your reply.

I have tried this. Put the pineapple into recovery with the last dip switch down etc.

BUT the problem I have is with the Ethernet cable connected etc it won't navigate to http://192.168.1.1. It simply times out or is unavailable. I have set up the correct static I'd etc via my Ethernet port.

I can't access the web interface at all -nothing.

Red light seems to indicate that the md5 checksum is wrong etc but I can't reset the pineapple -tearing my hair out with the thing.

Link to comment
Share on other sites

Thanks Sebkinne BUT:

In response to relevant info in the common questions (which I have already read)

"On my first boot, I get a solid red light.

If this happens the two files present on the SD card do not match each other. Please download one of the ZIP files from here and extract these to the root of the SD card, then try again."

As I said in my stated in my original question I have downloaded and extracted new files to the root of a newly formatted SD card but I still get the solid red light issue -still nothing more.

I can't get web interface at all -would this be the case if the files on the SD card were correct (or even corrupted)? Could my pineapple actually have a hardware failure rather than software?

Link to comment
Share on other sites

Hi all. please bare with me but i'm a novice with my pineapple

Having trouble with the SD card on my pineapple. I believe it may have been faulty from the box (as i have read of others having faulty cards)

Currently the pineapple has red & green light on and i can't get it to work - i believe the md5 is missing/corrupt?

I have then downloaded the latest software and added it to the card but i can't figure how to add the md5 checksum file from the download page? Is there something simple that I am missing?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...