Jump to content

wlan0 -> wlan1 (client mode) sslstrip not working?


mykrowyre
 Share

Recommended Posts

When I connect to the pineapple's access point (wlan0) from a simulated victim computer, and access the internet through wlan1 (which is in client mode), is there any reason sslstrip should not work correctly? When I enable sslstrip, the connection fails and the only way to restore it is to disable sslstrip and then drop to shell and restart the firewall. The routing table is correct, and forwarding is enabled.

My gut feeling is that it is going into a recursive routing loop, but I am not see anything the firewall config which could cause that, and it's been freshly reset, re-flashed, and only sslstrip infusion installed.

Out of curiosity I typed:

iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 10000

sslstrip -l 10000

And got the same result.

What am I doing wrong here?

Thanks

Link to comment
Share on other sites

I had the same issuse and did enabled SSLStrip first and then enabled ICS.

Maybe the order is important ?!

Thanks. Man I've tried everything. I've flashed and reset it hundreds of times. Tried using ethernet as the gateway, tried running sslstrip from shell, I just can't get sslstrip to work. It *has* worked in the past, occasionally, for one attempt, and then would stop working again.

I'll try starting sslstrip before ICS. Thanks

Link to comment
Share on other sites

Nope didn't work.

I've been fighting with this thing since day1, many issues not just sslstrip. Constant reboots, etc. Iptables and sslstrip are easy to use, but sllstrip absolutely refuses to work on my pineapple. I'm ready to toss it in my junk box and move on.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...