Jump to content

ALFA AWUS036AC


Pada1
 Share

Recommended Posts

I recently bought a ALFA AWUS036AC hoping to use it with my Kali distro. It says it is compatible with Linux Kernals 3.X but unfourtantely when I goto download the driver from ALFA i get the error that the driver has been removed or deleted, I was wondering if anybody could help me either get this wifi ant. working with Kali or point me in the direction of the best of the best kali wifi routers for penatration testing so I can return this one and get another that works.

This is the link that the ALFA website directs me to : https://www.dropbox.com/s/khbd9h7tosdid6o/AWUS036AC_linux_v4.3.2_11100.20140411.zip

Link to comment
Share on other sites

I *HIGHLY* doubt you need an external driver to get this card going. Kali (like any other decent distro) ought to simply support it out of the box. What does 'dmesg' say when you connect the adapter?

Link to comment
Share on other sites

Thanks for the quick replies.

The device is registering on my MacBook Pro, I know because when I plug it in the application pops up and the lights on the usb adapter are blinking.

As soon as I switch to my virtual box and change the usb device settings to reconize my usb ALFA device the light stops blinking.

I check iwconfig and all I see

root@kali:~# iwconfig

eth0 no wireless extensions.
lo no wireless extensions.
I tried the Tail -f /var/log/kernel command and I'm not getting anything I just copied and pasted like you told me, I've never used that command so I may need to customize it for my machine? This is what I get:
root@kali:~# tail -f /var/log/kernel
tail: cannot open `/var/log/kernel' for reading: No such file or directory
Link to comment
Share on other sites

What device are you plugging the adapter into?

Looking at the dmesg output it would appear that your device is detected and almost immediately disconnected. Typically that would imply that it tries to draw more power from the USB port than it's able to deliver. Forum member i8igmac had a similar problem when he tried connecting his Alfa card to his Raspberry. These Alfa cards swallow a _lot_ of juice. He measured 1.2 amps which is 0.7 amps above spec. Most PCs and beefy laptops can handle that. Low-powered devices typically do not. The fix to this sort of thing is to use one of those Y USB cables that connect 2 USB ports up for the one device - both ports are used to acquire the power but only one provides data. Alternatively (and probably more long-term viable), acquire a powered USB hub and run the adapter off of that.

Link to comment
Share on other sites

Great, that sounds like a solution, I have a early 2011 macbook pro, not so beefy. But is there an antenna I can get that will not require me to do this, that is dual band? Right now I have what I think is the newest ALPHA indoor antenna:

http://www.amazon.com/Alfa-Long-Range-Dual-Band-Removable-Connections/dp/B00MX57AO4/ref=sr_1_1?ie=UTF8&qid=1412518411&sr=8-1&keywords=AWUS036AC

It also says that it is a 3.0 device and I don't have a 3.0 usb port on my laptop. I was a thinking this looks like the best antenna they make and its only a few bucks more then the other ones, I guess this is a lesson learned the best is not always the most practical or best decision.

As far as finding a 1 to 2 usb dongle I can't find one, but will this hub do? I also have a firewire port on my macbook if I could do something with that?

http://www.amazon.com/Sabrent-Premium-Aluminum-MacBook-HB-UMAC/dp/B00EFE9OAE/ref=sr_1_6?s=pc&ie=UTF8&qid=1412518636&sr=1-6&keywords=usb+hub

Thanks Cooper

Link to comment
Share on other sites

I'd use this page as a guide for picking the appropriate USB hub. I'm sure the look of these alternatives will be extremely counter to the sleek look of a Macbook which you're just going to have to accept. You can try the one you chose, but if it, like your Macbook, adheres to the spec religiously it still won't work. It'll look mighty sharp though, I'm sure. :lol:

The point of the excercise is that not all powered USB hubs are equal. The official spec says 5V @ 0.5A per port MAX. The problem the Raspberry Pi has is that it tries to pull in a full 1A from its USB cable. If the powered USB hub can't deliver that, the Pi shuts down again. You're experiencing the exact same problem, but with a network adapter. Note that the device at fault here is the network adapter, pulling in over twice the power the spec allows the port to deliver.

Now, some powered USB hubs don't give a rats ass how much power each port pulls individually, so long as the total power consumption from the attached devices stays within the spec of its own power supply. You want *THAT* type of USB hub.

If I were to pick one of the hubs from that page, it would be one made by Plugable - either the USB2-HUB4BC or the USB2-HUB-AG7. If it doesn't work though, I accept ZERO responsibility. :smile:

I don't think Firewire can do much of anything for you on this front.

This is the forum post where i8igmac was having issues with his Alfa card in combination with his Pi. He bought a new powered USB hub which solved his problems, but he didn't mention the make or model. You could ask him...

Link to comment
Share on other sites

Edit... tail -f /var/log/kern.log helped me solve my problems... plug in and see what happens

I went into bestbuy and started to compare prices vs amp output...

15$ Usb hub 5v 2amp output is what I end up with...

I can recommend a temp fix, but with out fully understanding your situation, my device would disconnect during heavy transfer after associated

Iwconfig wlan0 rate 5.5M fixed

This would fix my problem with other wifi cards,

Edited by i8igmac
Link to comment
Share on other sites

If my wifi device is working with my macbook when it is running on the MAC operating system and then when I start up Virtual Box and plug in the deivce and choose it under devices/usb/Reltalk 802.11n (my wifi router) it shuts off.

With that said does that mean that the Vbox doesn't allow the usb to give full power to the wifi antena or am I missing something?

Link to comment
Share on other sites

https://github.com/lwfinger/rtlwifi_new/issues/9

That right there is the reason for the problem you're having. I effectively stopped reading the adapter model at AWUS036 but it would seem that this AC model is a brand spanking new one. And, as described in the issue, the Realtek engineers can't be bothered with making a proper driver so the end result is that at least for the time being your adapter isn't supported by Linux from within the main tree.

So, drop the hub idea. Time to roll your own kernel module.

You're going to need to include an out-of-tree driver to support the device (since the Realtek people won't provide one that can go in the tree), such as this one. Download and compile as per the instructions provided and holler back if you run into problems.

Edited by Cooper
Link to comment
Share on other sites

Wow, I'm embarking on new territory. I'm worried this is going to take me forever, because its all very new to me, but I'm excited to learn. I'm wondering if you could offer me any more reading material or yourtube videos on the subject.

I'm familiar with github but every time I use it I just plug it into the command line and linux does all the work I've never actually dissected or looked at the code. After opening the link you provided me I see a lot of files such as core, hal, include, Kconfig makefile etc. I opened the makefile and I see a 1085 lines of code. I'm guessing I have to edit this file to the specifics of my driver.

Question:

Am I on the right track?

Will I be editing all 1085 lines of code, or just certain sections of the code?

Where can I find the specifies on my router as far as what to change and what to change it to?

THANKS for your help

Link to comment
Share on other sites

Maybe not quite on the right track.

Start by finding your kernel source tree. There should be one on your system, probably in /usr/src and most likely in /usr/src/linux

If it's there, continue to the next paragraph. If it's not there, download the kernel tarball for the same version you're currently running (run "uname -s" to find out) and unpack at that location. Enter the directory it produces. If your system has a /proc/config.gz file, copy it to this directory, gunzip it and rename it to .config (note the dot at the start of the name) - this file contains the configuration of the currently active kernel and for a new one this is the best starting point.

Now that you have the kernel source, enter the ./drivers/net/wireless directory as this is where all these wireless drivers reside, and clone the github repository so you get the files onto your harddisk.

git-clone https://github.com/gnab/rtl8812au

This creates a directory named 'rtl8812au'.

Next, it's time to build things. Go back to the root folder of your kernel sources (/usr/src/linux or whatever) and run

make menuconfig

Navigate this menu structure using the arrow keys and look for this rtl8812au driver. The most likely location is

Device Drivers > Network device support > Wireless LAN

It should be there with "< >" in front of it. Navigate over it and hit space until that reads "<M>" meaning you want it included as a module.

Repeatedly hit the ESC key until it asks if you want to save your new configuration, select yes and you're back at the command prompt.

Compile the kernel (for good measure) and the modules like so:

make
make modules_install

Note that that last command and all commands that will now follow require su privs.

It should've produced a /lib/modules/<kernel-version> folder below which all your modules reside. Look for the 8812au.ko file which is the module for your network adapter.

Now, if you built this either using the existing kernel source tree or found an identical one (kernel version matches "uname -s" to the letter) you should now be able to run

modprobe 8812au

if the kernel name differs even slightly you should have at least 2 directories below /lib/modules - one for the kernel currently running and one for the kernel you just built. Locate the 8812au.ko file in the one tree and copy it over to the other in the exact same directory. Then, from that /lib/module/<currenlyActiveKernel-version> folder, run

depmod -a

You should now be able to run

modprobe 8812au

At this point the driver to your adapter should've been loaded. Connect the USB adapter and see if things have improved.

Link to comment
Share on other sites

  • 1 month later...

Cooper, I have been trying to do the same thing as the OP and I've successfully installed the forked driver for the ALFA AWUS036AC that you linked to on github. My issue now is that I am unable to put the card into monitor mode with the command: airmon-ng start wlan1 Is there something else I need to do in order to allow monitor mode to work or am I SOL?

Link to comment
Share on other sites

  • 2 weeks later...

Was the interface down when you started airmon-ng? I believe that's a requirement.

Hi Cooper, Ive been following you're instructions and when I try to use the make command I get:

Error 2 ; No rule to make target 'scripts/link-vmlinux.sh'

Could I have possible the wrong directory? (/usr/src/linux-headers-3.14-kali1-amd.64)

Sorry... Im a noob.

Thanks for all of your help so far.

Link to comment
Share on other sites

To write low-level code that talks to the Linux Kernel, you need the Linux Headers package which contains the C header files (files whose name ends in .h) that define the functions and their parameters which are exposed by the kernel.

The problem is that you're building a driver which isn't an app that talks to the Linux Kernel - it's to be a part of the running kernel. So you need the full Linux kernel sources rather than just the headers.

See if you can install a package or find an appropriate folder (indeed, typically in /usr/src and commonly named just 'linux') that provides this and then try again.

Link to comment
Share on other sites

  • 1 month later...

Has anyone succeded at making his instructions work? I'm always stuck at make menuconfig where the driver just doesn't show up in the list in Device Drivers > Network device support > Wireless LAN. I did git clone in the right place. I don't understand what this is supposed to achieve.

Here's what I tried so far:

I tried to compile + install the official driver from Alfa with

make
make install

I tried to compile + install the driver from:

https://github.com/abperiasamy/rtl8812AU_8821AU_linux
https://github.com/gnab/rtl8812au

with the same procedure of the Alfa driver.

I get complete freeze sometimes with some of these drivers while typing iwconfig.

Only thinkg that worked so far at lighting up the blue light is the procedure from here:

http://www.hackthistv.com/blog/alfa-awus036ac-how-to-install-drivers-for-linux/

I'll do some more tests later on, I'm a bit tired atm.

Link to comment
Share on other sites

  • 6 months later...

Here are the Gentoo instructions. The "scripted installation" is Gentoo specific but the "manual installation" below it should work pretty much everywhere.

If you run into issues, post them and I'd be happy to help you work them out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...