Jump to content

Tango Mode questions


Recommended Posts

Hi there,

i have some pineapple tango mode question. I'm useing the pineapple plug and an Alfa from the hakshop.
Enabled tango mode on PA2 with:

uci set network.lan.ipaddr=172.16.42.2
uci set network.lan.gateway=172.16.42.1
uci commit network

Tango mode works fine.

Pineapple 1 + connected Alfa
PA1 is connected with wlan1 to my Router (ICS)
wlan 0 is unsed (it is in AP mode per default ?!)
wlan 2 (Alfa) does deauth (whitelisted both PA + Router)

Pineapple 2
wlan0 -> collect clients (AP)
wlan1 is unsed
MK5 Karma & PineAP are enabled

wlan2 on PA1 is not needed because wlan0 can do the same ?

sslstrip should run on PA1 (Gateway for PA2) or PA2 ?
Is there a better loadbalacing for the services ?
DNS Spoof and URLSnarf on PA1 or PA2 ?
wlan2 suggestions ?

Greez

BeNe

Link to post
Share on other sites

The whole tango thing is pretty half baked at the moment as far as I can tell... Perhaps check back when the pineapple plug gains some more traction.

Essentially you have just two networked devices with the pineapple plug - nothing special or clever. Software needs to be written to make the most of this configuration for the pineapple - this takes time and hasn't been done yet.

Link to post
Share on other sites

Sebkinne, can you explain me the best solution for the tango mode ?

I'm sure the new firmware will handle the tango mode (more easier)

Thanks,

BeNe

Link to post
Share on other sites

Somebody else uses the TangoMode ?

I'm playing around with it since i get no answer for my question. Seems that sslstrip in some situations kill the uplink or the iptables from PA1 <-> PA2.

Here are (still) unanswered questions:

  • wlan2 on PA1 is not needed because wlan0 can do the same ?
  • sslstrip should run on PA1 (Gateway for PA2) or PA2 ?
  • Is there a better loadbalacing for the services ?
  • DNS Spoof and URLSnarf on PA1 or PA2 ?
  • wlan2 suggestions ?
Link to post
Share on other sites

The load in TangeMode is still to heavy -> Pineapples are rebooting :angry:

Clients recieve a timeout when they are surfing.

Does it make more sense that PineApple2 runs pineAP and Karma and PineApple1 does ICS ?

So can i select on which Pineapple SSLStrip, URLSnarf is running because PineApple1 is the Gateway and the data need to go through it from Pineapple2.

I can catch the data on Pineapple2 or catch them on Pineapple.

Right ? Suggestions ? Answer for my questions ?

Link to post
Share on other sites
  • 3 months later...
  • 3 weeks later...
  • 2 months later...

I grabbed the Pineapple Plug and a 2nd MKV around XMAS, along with the Ominous Box and the Pineapple HDK lol. I haven't made use out of any of it. There was mention about better Tango function for the Plug in a fw release back when i bought it as well as a Hak5 segment about the HDK, dunno if that's still in the picture (I hope so). I had the same rebooting problems as you. Til the load balancing gets sorted out, it's just more problems than it's worth. Hopefully someday i'll use em.

Once i saw the ominous Box in person i laughed my ass off tho. I call it the "Biggest Most Obvious Little Dropbox In Texas" lol. It takes up like half the wall, i think it was on sale for like 10 bux tho so it's all good.

The Plug & HDK are good ideas tho, just need a little attention. It's not like there's a whole army of people working on development of Pineapple/Hak5 niches tho. I'm dyin to find out what the Turtle's gonna end up being. I have no idea what it is, but i know Darren's gonna make it look like something that i need in my life, then Shannon's gonna get all excited about it, then i'm gonna punch in my credit card for em again :tongue:

Link to post
Share on other sites
  • 4 months later...

@Sebkinne @Darren Kitchen

will the "Tango-Mode" ever be available in a future Firmware ?

I ask the same question again and again for about ~1 year without any comment - that´s hard :huh:

Seb said in the Video "WiFi Pineapple 2.0.2 Firmware - PineAP" on Youtube

"The firmware we will bring it out will make it super easy..."

Here is the part @ 37m -->

So, what happend ?

Edited by BeNe
Link to post
Share on other sites
  • 5 months later...
  • 2 months later...

Yeah I was kind of curious about that as well. :( Kind of a waste for the plug. Have two Mark Vs and a plug. It was fun but really had a lot of issues with the hardware regardless. They work fine, but I'll probably find a dedicated use for my Mark Vs and work more with my nano. If I ever get the resources and approval from the wife I might get the Tetra.

Link to post
Share on other sites
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...