Jump to content

Openwrt sysupgrade for nand devices


Recommended Posts

Good day all, some time ago I have compiled my first OpenWRT image and successfully write it on my router with nand flash. But now, when I made all networkk setup I see the error message when trying to install php+nginx.

opkg install php5-fastcgi nginx
Installing php5-fastcgi (5.4.33-1) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/packages//php5-fastcgi_5.4.33-1_ar71xx.ipk.
Installing nginx (1.4.7-2) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/packages//nginx_1.4.7-2_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for php5-fastcgi:
 *      zlib *  libpthread *    zlib *
 * opkg_install_cmd: Cannot install package php5-fastcgi.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for nginx:
 *      libopenssl *    zlib *  libpthread *
 * opkg_install_cmd: Cannot install package nginx.

Seems that my version is too old for this packages, or not?

what the problem can be?

And I would like to ask you the main question, when I compile new OpenWRT image for update, what kind of image I should use in make menuconfig->target images?

and then, when I compile it, I will update it with

sysupgrade -v openwrt.bin

Is that right way?

My final target to learn how to install and config nginx with PHP on OpenWRT and sucssesfully made it!

thanks a lot, for all unswers!

Regards Andrey.

that the present on my birthday, from me and hak5 shop and I like it.


Edited by drix
Link to comment
Share on other sites

seems that all good, php working and nginx, but my site doesnt. dont know why.

what I do:

first of all disable uhttpd


opkg update
opkg install nginx php5 php5-fastcgi 



user nobody nogroup;
worker_processes  1;

error_log  logs/error.log;

events {
    worker_connections  1024;

http {
    include mime.types;
    index index.php index.html index.htm;
    default_type text/html;
    sendfile on;
    keepalive_timeout 65;
    gzip on;	
    gzip_buffers     4 16k;
    gzip_http_version 1.0;
    gzip_comp_level 2;
    gzip_types       text/plain application/x-javascript text/css application/xml;
    gzip_vary on;
    gzip_min_length  1k;

    server {
        listen	80; # слушающий порт
        server_name; # имя или ip-адрес сервера
        fastcgi_connect_timeout 300;
        fastcgi_send_timeout 300;
        fastcgi_read_timeout 300;
        fastcgi_buffer_size 32k;
        fastcgi_buffers 4 32k;
        fastcgi_busy_buffers_size 32k;
        fastcgi_temp_file_write_size 32k;
        client_body_timeout 10;
        client_header_timeout 10;
        send_timeout 60;
        output_buffers 1 32k;
        postpone_output 1460;
        root   /srv/www;		# Папка с файлами сайта
        location ~ \.php$ {
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
            include        fastcgi_params;
            if (-f $request_filename) {

doc_root = "srv/www"
cgi.force_redirect = 1
cgi.redirect_status_env = "yes"; 
/etc/init.d/nginx enable
/etc/init.d/nginx start
/etc/init.d/php5-fastcgi enable
/etc/init.d/php5-fastcgi start 

than test phpinfo, all good!


but when I'm trying to run my website I have got


dont understand why that happend, somebody, pls explain me :wacko:

seems that script trying to define browser type and cant do it. hm.... :huh:

Edited by drix
Link to comment
Share on other sites

seems that all good, I have not installed necessary packages

opkg update
opkg install php5 php5-mod-apc
opkg install php5
-mod-gd php5-mod-session
opkg install php5-mod-pdo-mysql php5-mod-pdo php5-mod-mysql
opkg install php5-mod-mcrypt php5-mod-mbstring php5-fastcgi php5-cgi php5-mod-xml php5-mod-ctype php5-mod-curl php5-mod-exif php5-mod-ftp php5-mod-iconv php5-mod-json php5-mod-sockets

and php.ini

Edited by drix
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...