Jump to content

Unable to connect to MK5 to the internet via Kali Linux on Macbook Pro


abhartiya
 Share

Recommended Posts

First things first - I have already gone through a bunch of posts on this forum but none of them have been helpful to solve the specific problem that I am having so any help here is greatly appreciated.

My setup is something like this:

MK5

Kali Linux installed on Virtual Box sitting on Mac OSX 10.9.4

The network settings of the Kali Linux Virtualbox is set to "NAT".

So, when I type in ifconfig inside Kali, I see just 2 interfaces:

eth0 with an IP address of 10.0.2.15

lo with an IP address of 127.0.0.1

On my macbook, I have a bunch of interfaces. The important ones are listed below:

en0 with an IP address of 172.16.42.210 - This is the ethernet interface connected to the MK5.

en1 with an IP address of 192.168.1.3 - This is the wifi interface connected to my router

Straight out of the box, I was able to successfully connect to MK5 via ethernet and fire it up. No problems there.

I could reach to it from the macbook as well as Kali.

After starting it up, I noticed there was no internet access on the MK5. So, I read some posts and figured that MK5 has 2 wlans now.

So, I enabled Wlan1 from the portal, navigated to Client Mode. Scanned for my router's SSID and connected to it.

I now had internet access on my MK5 so I upgraded the firmware, installed infusions, etc.

I also had internet access on any other device connected to my MK5 via MK5's broadcasted SSID at Wlan0.

So, everything till now looks good. I have my MK5 setup and running with internet access.

I can connect any device to MK5 and have internet access to it.

I can access Mk5's portal from both my Macbook and Kali.

I can also run infusions like tcpdump, sslstrip, etc. on the Mk5 itself.

So, on one hand I have my Macbook and Kali connected to the router and on the other hand, I have my MK5 connected to the router as well.

And, I am able to access Mk5 from my Macbook/Kali via the ethernet port.

However, the above setup is not something I want because all traffic sent to MK5 is automatically sent to the internet via the router because Wlan1 is enabled on Mk5.

What I want is:

Wlan1 be disabled so that only Wlan0 is open on the Mk5 broadcsting its SSID.

All the traffic sent to the MK5 should be routed via Kali on my Macbook and then onwards to the router so that I can run tools on Kali and capture the traffic.

I understand this means I will be sharing my internet from the wifi port of my macbook onto the ethernet port for the Mk5 to connect.

But, I have read that the ICS on macbook should not be enabled because it changes the IP address?

So, how do I get this working when the Wlan1 is disabled on the Mk5 and ICS is turned off on Macbook?

Also, since i really want to be doing all this on the Kali VM rather than the Macbook, I downloaded the wp5.sh script from wifipineapple.com and ran it on the Kali VM.

Pineapple Netmask: 255.255.255.0

Pineapple Network: 172.16.42.0/24

Interface between PC and Pineapple: eth0 ----> not sure what this should be since I'm on the Kali VM?

Interface between PC and Internet: wlan0 ----> I only see eth0 and l0 listed on Kali so what value should I enter here? en1 of macbook?

Internet Gateway: 10.0.2.2

IP Address of Host PC: 172.16.42.210

IP Address of Pineapple: 172.16.42.1

I am not sure the above values are correct or if the scenario I describe here is even possible?

Can somebody please assist?

Thanks

Link to comment
Share on other sites

I am not sure I completely understood your suggestion.

The cable that comes with MK5 isn't a crossover cable?

I switched from NAT to Bridged. The Kali got a new IP address on eth0: 172.16.42.224

I then disable WLAN1 on MK5.

After that, I could reach to the MK5 portal obviously because its on the same subnet.

But, I could not connect to the internet.

I enabled the WLAN1 on MK5.

I was able to connect to the internet.

So, I guess what happened was that the traffic from Kali started going out to the MK5 and then to the internet via WLAN1.

That is not what I wanted in the first place.

I want traffic from WLAN0 of MK5 -> ethernet to Macbook -> Bridged to Kali -> Out to the router

Link to comment
Share on other sites

This doesn't help because that is not how I have my setup. In the above video, it looks like Ubuntu is the Host OS and is not running on a VM inside the Host.

That is why, there was an option to choose both eth0 and eth1 (ethernet to pineapple and wifi to internet). So, running the wp4.sh script works just fine.

For me, that is not the case. Since I am running Kali inside VirtualBox on my Mac, the only interface I see is eth0 (bridged to Mac) on the Kali.

Does that make sense?

Link to comment
Share on other sites

One, you don't need a crossover, Macs have had gigabit ethernet since the old titanium G4s. Gigabit will autocross. Don't NAT the network, put it in bridge mode. ICS in osx is useless for the pineapple, don't bother. Use a usb network adapter connected directly to Kali, set it's ip address to the standard 172.16.42.42. Then you can run the ics script from the usb to the built in virtual nic, then out the Mac.

Link to comment
Share on other sites

Hey, whether you know it or not, I think you're answering your own question here:

Interface between PC and Pineapple: eth0 ----> not sure what this should be since I'm on the Kali VM?

It looks like your kali vm does not have any connection to the pineapple as currently configured. Assuming your eth0 is routed to the internet already, create another virtual adapter and bridge it to your mac's en0. After that, you should have the answer to the two confusing questions in the wp5.sh helper script:

Interface between PC and Pineapple: eth0  ----> eth1 (The bridged adapter you just created) 

Interface between PC and Internet: wlan0 ----> eth0 (Kali's NAT connection to the internet)

Does that help?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...