Jump to content

Pineapple seems dead --


jerome
 Share

Recommended Posts

Hi all--

My wifi pineapple mkv worked for a while, then I didn't use it for a few months. Upon restarting, it boots, all the lights flash and then it ends up on only green. There's no Wifi signal visible and no activity on the ethernet port.

I've successfully flashed via ethernet with the unbrick procedure but it fails to boot again when the switches are placed back all up.

The SD card is blank even after the unbricking (verified correct md5), I formatted and unbricked again but; no luck.

I'm not certain I'm performing the unbrick correctly as the instructions in the following post point to "stager.bin" but it isn't available for download. There's also no zip file as referenced in the post.

https://forums.hak5.org/index.php?/topic/31637-micro-sd-unbrick-issue/

I did try putting the .bin on the sd card as well as the md5 sum in a file called md5.txt -- nada.

I've ordered a new sd card but, in another computer the sd card seems to work so not confident it will help.

Any help or a working link to stager.bin and the sd card zip would be greatly appreciated.

Thanks,
JM.

Link to comment
Share on other sites

This happened to mine, had to do a hard factory reset.

To conduct a hard reset place dip switches 2 and 3 in the down position.

Wait for the image to be re flashed and then accessed the pineapple.

Once you have access the webUI flip the dips witches back up and continue.

Edited by damavox
Link to comment
Share on other sites

hi damavox -- thanks for the reply. I did try the dip switches 2 and 3 in the down position waited for more than 20 minutes, then power cycled with switches back up, It just ends up with the green light on.

Next I moved to flashing the factory image from the flashing page above (switch 5 down). Still no joy.

eth0 works for uploading the factory image, but is dead with all switches up.

Link to comment
Share on other sites

Hmmmm strange. Try to format your sd card to a earlier firmware version 1.4.x or below, load the image to the sd card and go back through the steps of flashing via sd card.

This doesn't work anymore, sorry. Please see how to factory reset your WiFi Pineapple on our website.

Best regards,

Sebkinne

Link to comment
Share on other sites

Thanks for all the suggestions everyone. I've tried multiple cards, fat and ext formatted, and the flashing instructions on the wiki as well as the factory reset in all sorts of combinations and on different computers. I'll be sure to post what I find when I get the serial adapter.

thanks again!

Link to comment
Share on other sites

Power Supply! Along with the usb serial I also received a usb to barrel power connector -- I tried that first. It works,

Theory:

It looks like a brown-out.

Supporting Data:

While the system is first booting it looks fine until... the radios fire up, then there's enough of a current draw to cause a voltage dip and crash the OS. (no radios during unbrick, so, lower current?)

Would love to power test the ps, also watch serial during boot and measure current draw, but hey it's working --

thanks for all the suggestions!

Peace!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...