Jump to content

USB to RJ45 adapter ?


fredoldodo
 Share

Recommended Posts

Hello,

I'm trying to use my USB to RJ45 adapter on the USB port of the pineapple but I'am unable to get an IP address with my PC when i connect to it.

Is there a DHCP server to activate (on eth1) ? (I'm using eth0 to connect to a raspberry pi)

here is a "ifconfig eth1":

eth1 Link encap:Ethernet HWaddr 9C:EB:E8:0D:88:72
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Or perhaps something other to do ? How can I get it working ?

Thanks for your help, :grin:
Frédéric.

Link to comment
Share on other sites

Hey,

Thank you for your reply. :smile:

Here is my /etc/config/wireless, but I can't get eth0 and eth1 simultaneously working:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '172.16.42.1'
option netmask '255.255.255.0'
option gateway '172.16.42.42'
option dns '8.8.8.8'

config interface 'lan2'
option ifname 'eth1'
option type 'bridge'
option proto 'static'
option ipaddr '172.16.42.1'
option netmask '255.255.255.0'
option gateway '172.16.42.42'
option dns '8.8.8.8'

config interface 'wan'
option proto 'dhcp'

config interface 'usb'
option ifname 'usb0'
option proto 'dhcp'

config interface 'wan2'
option ifname 'ppp0'
option proto '3g'
option service 'cdma'
option device '/dev/ttyUSB0'
option apn 'pinternet.interkom.de'
option username ' '
option password ' '
option defaultroute '1'
option ppp_redial 'persist'
option peerdns '1'
option dns ' '
option keepalive '1'
option pppd_options ' '


Link to comment
Share on other sites

Before mucking about with dhcp and the config files, can you verify that you can achieve what you're after manually?

Based on your first message it does seem the interface comes up, so no sense in lsusb. Wondering what chipset however. What do you get in logread when plugging in the device?

Are you able to manually give it an IP address in the range of your desired network? Ie ifconfig eth1 192.168.1.101 netmask 255.255.255.0 up

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...