Jump to content

MkV unresponsive after attempt at sysupgrade to 2.0.3


Recommended Posts

I have had the MKV for only a few days. (i.e. brand-new, not abused, etc.)

Today I upgrade from the factory flash to 2.0.2. This was successful.

I then noticed that there was a 2.0.3 version available. I downloaded this and checked the md5. I decided to do the upgrade via ssh.

Per the instruction I then did the sysupgrade command:

sysupgrade -n -v /tmp/upgrade-2.0.3.bin
Sending TERM to remaining processes ... atd crond nginx php-fcgi-daemon sh php-fcgi dnsmasq ntpd sleep syslogd klogd hotplug2 ubusd mobile-keepaliv netifd
Sending KILL to remaining processes ... ntpd sleep
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ... [w]

writing from <stdin> was NOT what was expected.

Figuring that the best solution was to power cycle and if needed to a factory reset. Thats what I tried.

Unfortunately, I have not been able to do the factory reset:

  1. I powered off.
  2. Set DIP#5 in the down position.
  3. Powered on.
  4. All lights lit.
  5. Then just green and red.
  6. plugging in the ethernet cable got the a self-assigned ip message.
  7. and the yellow light... but no connection
  8. I set ifconfig en0 inet - unsuccessful
  9. Then I tried ifconfig en0 inet

So this meant I could not use the web ui.

Next I tried the Factory DIP switch factory reset: ( http://wiki.wifipineapple.com/index.php/Factory_Reset )

Now I just get just the red and green lights. And now no yellow light.

Additional info:

  • I am using the right power supply. ( i also tried the battery as well )
  • the ethernet cord is the brand-new ethernet cable that the mkv shipped with.
Link to comment
Share on other sites

Well I don't know what I did but...

  1. power cycled.
  2. Did factory reset with DIP switches
  3. powercycled
  4. put DIP normal mode
  5. power cycled
  6. put just DIP#5 in down position
  7. power cycled
  8. each time i left the power on for a few minutes

Finally, in the DIP #5 off position, the mkv lights started blinking in the happy pattern.... and I could connect and do the initial upgrade to 2.0.2 version.

But how come the sysupgrade wanted to take the input from the stdin?

What is the UART?

Link to comment
Share on other sites

Your output from the sysupgrade was completely normal, and you shouldn't of CTRL+C'd it.

The only way I think you'll get back in is with a UART.

What should I have done?

Ctrl-D ?

Why is the sysupgrade taking anything from <stdin> when the image was on the command line.

Link to comment
Share on other sites

What should I have done?

Ctrl-D ?

Why is the sysupgrade taking anything from <stdin> when the image was on the command line.


Video shows how to upgrade the firmware. It will say Rebooting System when its ready to be used.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...