Jump to content

bully won't work with Mk V?


Go to solution Solved by AlexJeb,

Recommended Posts

I've been trying to run bully, but it just fails on me. I grabbed the command line generated by the wps infusion and I got this:

root@Pineapple:~# bully mon0 -b 08:63:61:C3:D2:E4 -e "some_ssid" -c 11
[!] Bully v1.0-22 - WPS vulnerability assessment utility
[+] Switching interface 'mon0' to channel '11'
[!] ioctl(SIOCSIWFREQ) on 'mon0' failed with '-1'
[X] Unable to set channel on 'mon0', exiting
Maybe something missing in the kernel? "mon0" is a monitoring interface on wlan2 (the ALFA radio) but I've also got the same failure with mon0 on wlan0...
Link to post
Share on other sites
  • Solution

I'm curious, when ur trying this is ur WLAN0 (if ur using wlan0 for the mon0) set to up? If so, that's ur problem. With it up, it sort of locks the device onto a certain channel. Try with "ifconfig wlan0 down" and see if that helps.

Link to post
Share on other sites

I'm actually using wlan2, which is a plugged-in USB ALFA radio adapter. I purposely set up mon0 on wlan2 to avoid getting the channel locked up into something else.

I monkeyed around and set up mon1 on wlan1, as wlan1 was in connected to the target AP in client mode, so it made sense to try it this way. bully actually worked for a while, at least until the AP locked me out. Then after a couple of minutes it tried to switch channels and that's where it gave me the same message again.

Maybe bully is trying to use an ioctl operation that isn't supported by the drivers?

Link to post
Share on other sites
  • 2 weeks later...

Latest update: I finally was able to run bully. n00b mistake: I was having what is referred to as the "-1 channel bug" which happens when you enable monitor mode while having the associated wlan interface enabled. I disabled wlan2, started mon0 and voila! It works! Thanks, AlexJeb; yes it was wlan2 being enabled...

Edited by danixdefcon5
Link to post
Share on other sites

Latest update: I finally was able to run bully. n00b mistake: I was having what is referred to as the "-1 channel bug" which happens when you enable monitor mode while having the associated wlan interface enabled. I disabled wlan2, started mon0 and voila! It works! Thanks, AlexJeb; yes it was wlan2 being enabled...

Maybe this is a n00b mistake as well, lol, but when you say disable wlan2, i'm confused because I have wlan0 and wlan1?

Link to post
Share on other sites

Maybe this is a n00b mistake as well, lol, but when you say disable wlan2, i'm confused because I have wlan0 and wlan1?

A lot of Pineapple owners are buying this at a special discount. If you plug in another supported WiFi dongle, you'll have wlan2 too.

Edited by fringes
Link to post
Share on other sites

In response to d0n350n:

If you are enabling mon0 via wlan0 then in order for the mon0 to not have the locked channel, you need to "ifconfig wlan0 down" after enabling mon0. If u keep the wlan0 interface up, it stays locked on a certain channel. If you plan on using wlan1 to enable mon0 or others; same deal, you have to turn the wlan1 interface down after enabling the monitor. Same if u had more interfaces ie: wlan2. Hopefully this helps guys!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...