Jump to content

Point-to-Point pineapple network


Sup'air
 Share

Recommended Posts

Hello to everyone,

I am trying to setup the following network with two pineapples. The aim is to stream a webcam flow from Laptop 1 to Laptop 2.

http://hpics.li/45bb2a4

But I am getting some troubles to connect the pineapple together.

Each pineapple is physicaly connected to a computer with ethernet cable. The network is 172.16.42.0 /24 on this link.

So my question is : What is the network between the two pineapples ?

Thanks for your help :smile:

Sup'air

Link to comment
Share on other sites

So my drawing was false.

But when I connect the pineapple_2 to the pineapple_1 I am sure I am with this configuration : (pineapple_1 wlan 0) ============== (wlan 1 pineapple_2).

network ?

(pineapple_1 wlan 0) ============== (wlan 1 pineapple_2)

But what is the network between the two pineapples ? It can not be 172.16.42.0 /24 right ?

Do you see what I mean ?

Sup'air.

Link to comment
Share on other sites

Point-to-point would be something like 192.168.0.0/30 for the network. This leaves:

192.168.0.1 and 192.168.0.2 as the usable addresses.

Seb has the easiest way to make what you want to do work. Use wlan1 as the client, and wlan0 as the access point

If you have trouble make a backup of /etc/config/network first (name it something easy like network.orig). Then change /etc/config/network to a different network for the eth network (under the section named "config interface lan"). This should make the wired network different from the wireless network.

Link to comment
Share on other sites

Hello jmelody and thank you for your help,

In my scenario, [wlan1 of pineapple_2] will connect to [wlan0 of pineapple_1]

If I understand you well, I have to do this :

pineapple_1 :

Change the wlan0 network to for example 192.168.0.0 /24 netmask 255.255.255.0

pineapple_2 :

I leave the wlan1 configuration with dhpc (pineapple_1 will give an @IP to pineapple_2) :

config interface wan
option ifname wlan1
option proto dhcp
Am I right ?!
Sup'air
Link to comment
Share on other sites

Sorry, my example was for wired connection to the pineapple with the end devices.

The pineapple being used as the AccessPoint (AP) will use DHCP to give the connecting pineapple (the one using client mode) an address (I believe it will be 172.16.42.228). Is that not the case when you try to setup the network?

I thought you were having trouble with the wired end not playing nice with the wireless network.

Edited by jmelody
Link to comment
Share on other sites

Hello,

I do the network setup from the beginning, without modify the IP address : pineapple_2 connects to pineapple_1 with wlan1.

Below is the network configuration for each pineapple :

pineapple_1 :

root@Pineapple_1:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:13:37:A5:23:52
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6777 errors:0 dropped:119 overruns:0 frame:0
          TX packets:4196 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:632429 (617.6 KiB)  TX bytes:704364 (687.8 KiB)

eth0      Link encap:Ethernet  HWaddr 00:13:37:A5:23:52
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:5756 errors:0 dropped:24 overruns:0 frame:0
          TX packets:3563 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:620004 (605.4 KiB)  TX bytes:616844 (602.3 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1712 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1712 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:151600 (148.0 KiB)  TX bytes:151600 (148.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:13:37:A5:23:52
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1096 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1760 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:116112 (113.3 KiB)  TX bytes:200994 (196.2 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:13:37:93:5B:38
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

pineapple_2 :

root@Pineapple_2:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:13:37:A5:23:43  
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5522 errors:0 dropped:31 overruns:0 frame:0
          TX packets:5093 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:594967 (581.0 KiB)  TX bytes:676740 (660.8 KiB)
eth0      Link encap:Ethernet  HWaddr 00:13:37:A5:23:43  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5529 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5093 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:672793 (657.0 KiB)  TX bytes:676740 (660.8 KiB)
          Interrupt:4 
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:296 errors:0 dropped:0 overruns:0 frame:0
          TX packets:296 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:27304 (26.6 KiB)  TX bytes:27304 (26.6 KiB)
wlan0     Link encap:Ethernet  HWaddr 00:13:37:A5:23:43  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:1640 (1.6 KiB)
wlan1     Link encap:Ethernet  HWaddr 00:13:37:93:58:C8  
          inet addr:172.16.42.192  Bcast:172.16.42.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1057 errors:0 dropped:51 overruns:0 frame:0
          TX packets:330 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:67493 (65.9 KiB)  TX bytes:37441 (36.5 KiB)

We can see that wlan1 on pineapple_2 got its @IP through DHCP : 172.16.42.192

But why am I not able to ping pineapple_2 from pineapple_1 :

root@Pineapple_1:~# ping 172.16.42.192
PING 172.16.42.192 (172.16.42.192): 56 data bytes
^C
--- 172.16.42.192 ping statistics ---
61 packets transmitted, 0 packets received, 100% packet loss

Sup'air.

Link to comment
Share on other sites

Thank you for the link, it was very helpfull.

But I still have some questions :

I have connected the first node to our LAN : 130.191.160.0 /24. But the university network is using DHCP to give address. So, in /etc/config/network should I replace this :

config interface lan
    option ifname    eth0
    option type     bridge
    option proto    static
    option ipaddr    172.16.42.1
    option netmask    255.255.255.0
    option gateway  172.16.42.42
    option dns    8.8.8.8

by this ?

config interface lan
    option ifname    eth0
    option type     bridge
    option proto    dhcp

Thank you for your help.

Sup'air

Link to comment
Share on other sites

Pretty sure what you need to do is set up the wireless from the network tile. Go to Access Point and set the ssid, channel and encryption/password. Then set the eth0 to dhcp,

config interface lan
        option ifname   eth0
        option type     bridge
        option proto    dhcp
#       option ipaddr   172.16.42.1
#       option netmask  255.255.255.0
#       option gateway  172.16.42.42
#       option dns      8.8.8.8

and completely disable the dhcp server on the first pineapple, comment out all the dnsmasq part of /etc/config/dhcp.

#config 'dnsmasq'
#       option 'domainneeded' '1'
#       option 'boguspriv' '1'
#       option 'filterwin2k' '0'
#       option 'localise_queries' '1'
#       option 'rebind_protection' '1'
#       option 'rebind_localhost' '1'
#       option 'local' '/lan/'
#       option 'domain' 'lan'
#       option 'expandhosts' '1'
#       option 'nonegcache' '0'
#       option 'authoritative' '1'
#       option 'readethers' '1'
#       option 'leasefile' '/tmp/dhcp.leases'
#       option 'resolvfile' '/tmp/resolv.conf.auto'
Reboot or just do a
/etc/init.d/network restart

What this will do is give your pineapple a dhcp ip address from the school network, and also allow any client you connect to the wireless you set up a dhcp address from the school network. Now from your second pineapple just use client mode to connect to your first pineapple's wireless and you "should" get normal pineapple network ip address from your wired and wireless network. I say "should" because I only have one MKV pineapple so I only set up pineapple 1 on my pineapple, pineapple 2 is just our standard client mode pineapple, that most of us have already used for getting updates and infusions.

The only downside to all this is you no longer know what the first pineapple's ip address is...

Link to comment
Share on other sites

Hello barry99705,

Thank you, this is very well explained. I did all of this.

If I connect my laptop directly to pineapple_1 with Wi-Fi, I have Internet access. Good thing ! And if I look my IP @, it equals to the university LAN (130.191.160.0 /24) :

IPv4 Address................... : 130.191.160.35(Prefered)

Then I connected pineapple_2 as client to pineapple_1.

Wlan1 in pineapple_2 got also a IP @ :

wlan1    inet addr: 130.191.160.20   Bcast: 130.191.160.255    Mask: 255.255.255.0

Finally I connected my laptop to the last node (pineapple_2). But unfortunately I can not access Internet.

Even from pineapple_2 when I ping 8.8.8.8. No response....

My laptop IP @ is :

172.16.42.199

I can ping pineapple_2 (172.16.42.1) and vice versa. But that's all :(

Sup'air.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...