Jump to content

USB testing and connecting devices


Hike
 Share

Recommended Posts

I'm having trouble getting any of my USB wifi appaters to power up and/or show up with ifconfig or iwconfig. I've got all 4 lights going on the pineapple and currently using it's wifi between my ap and laptop. Going into configuration infusion and running 'lsusb' returns the following. Executing 'lsusb': Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter Bus 001 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader Bus 001 Device 007: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

What would be the best way to test the USB port on the MarkV? Any other ways to start trouble shooting this or better googling terminology. I keep hitting dead ends. Is there a tutorial/wiki that I've missed out on?

The adapters used thus far:

AWUS036NHR

small unknown no-name usb wifi dongle

USB thumbdrives will light up... this is next on my list of todo's https://scotthelme.co.uk/wifi-pineapple-usb-storage-and-infusions/

thx,

H

Link to comment
Share on other sites

From my experience with trying to connect a blue tooth adapter the lights won't light up until a correct "driver" is installed. Try connecting the device to a wall outlet with USB adapter of course. lol. If the lights don't light up then drivers need to be installed to make them light up.

I've had problems installing dbus, and other addons partially due to having to be installed on the sd card the paths get jacked. And possibly kernel issues.

Best bet check openwrt and ddwrt fourms.

Good luck

Link to comment
Share on other sites

  • 3 weeks later...

I thought that I would update the status. As Darren has posted elsewhere the 36NHR is unsupported [yet?]for the Pineapple. I wish I had started by looking at the wiki - http://wiki.wifipineapple.com/index.php/Compatible_Wireless_Cards.

Duh!

There was nothing wrong with the USB and I've tested a 38NHA that worked wonderfully out of the box. The NHR will only light up during a connection to an AP (raspberrypi) vs lighting up as soon as I plug it into a windows machine. Trying to save infusions to the USB thumbdrive only confused the issue. Saving infustions to the USB on the MKV was answered (no, nada, and only on the MKIV)... see: https://forums.hak5.org/index.php?/topic/33119-usb-install-unavailable/

I've yet to load the drivers for the NHR on the MKV ( http://www.alfa.com.tw/press_c_show.php?sn=5 ). The NHA works....

Thanks and adios!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...