Jump to content

Metasploit Problem!


Computer_Security
 Share

Recommended Posts

So I have been having this problem for like a week now and I can't figure out why.

The problem is that when ever I try to start up a session of Metasploit or Armitage it gives me a error message saying that it couldn't connect to the database!

Armitage's Error Message

Could not connect to database.

Click Help button for troubleshooting help.

Connection refused Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.

Metasploit Error Message

Failed to connect to database: Could not connect to server: Connection Refused

If anyone could give me some suggestions on how to fix it I would be very grateful! If any more information is needed please tell me!

Link to comment
Share on other sites

Guest spazi

I have the same problem in Kali.
You need to start up postgresql and metasploit.
type this in before you start up Armitage.

service postgresql start

service metasploit start

then start up armitage and it should work just fine :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...