Jump to content

New Pineapple Mk V Problems


Recommended Posts

Hi there

Well today my beatiful little box arrived but I've run into some problems which are probably me being a noob.

1.

Put the aerials on - put the microSD card in and powered it up.

2.

Caffeine

3.

Went back 10 minutes later and lo and behold, we see a red/blue/amber pattern - deep joy - the most wonderful pattern in the world!

4.

Connected an ethernet cable opened a browser on Windoze 8 PC and went to :1471 -- Nothing - tried three times.

Oh well, I noticed that the "PineappleV" - SSID appeared so I connected to that and lo and behold- we are in.

Set the password - and looked at the panels. Green has become a fantastic colour

5.

Went to the infusions panel and it tried to connect to the internet to do what it has to do. Nothing. Of course not. There is no internet connection because the cable was plugged into my PC.- Or so I thought. The cable was connected nowhere. Just a dangling cable from the MKV- I think the word is "bugger".

6.

Connected the ethernet to the internet. Nothing. Oh well, lets restart the box.

7.

Powered down - count to 10 - power up.

8.

caffeine

9.

We no longer have Red Blue Amber pattern (Was this just for initial boot?)

10.

We have green Green Solid and Blue/Amber pulsing (NOT Blinking) - looks like a general data pulse.

11.

Noaccess so factory reset with dip switches. // red blue amber pattern.

12.

Rset dip switches - all up

12.

ethernet into the Box and go to :1471 // Set password and goto panels.

I don't see how I can get onto the internet to update the thing without there being ethernet and then I cant wifi into the box.

I really need help because I'm now a standstill

Thanks and regards

Link to comment
Share on other sites

Hi.

The flashing leds you described are to indicate a (succesfull) firmware flash has been completed. Therefor its a first time thing only, or when you (re) flash it with new firmware.

as for getting internet on the MK5. If i understand you correctly you plugged ethernet fromyou laptop / desktop into the pineapple? You need either internet connectionsharing enabled on your windows box, or go to the network tile, click netword and on the third tab youlle find client mode. Use wlan 1 to scan and connect it to your home wifi. Presto. Update and install with goodies.

Link to comment
Share on other sites

Still having problems I'm afraid.

1.

Back to Factory default - OK

2.

Cant access :1471 by Wifi. Accessed OK by Ethernet. Set the password.

3.

I restarted again and connected the MKV to the internet by ethernet

4.

Connected to WIFI but cannot access :1471.

Any ideas? I don't want to share connection with the PC - I really dont want to play with Widoze.

I tried previous to use WLAN1 to connect to my home router but it wouldn't sync up to it.

I would prefer to connect to the Internet by ethernet and use wifi to contol the MKV

I really am stuck

Thanjs

Link to comment
Share on other sites

You should see Pineapple_x_xx or somthing as your default access point.

My suspect is your PA DHCP not giving you a ip.

after step 2 : when you connect to your accesss point name. whats your IP address?

you may need to manually set your wifi IP.... I have had some simular issues - but not for a while.

IP 172.16.42.30

Mask : 255.255.255.0

gatewaye/router: 172.16.42.1

Now.. go to your client connections under network and connect to your home access point, enter in your authenticaed network password and connect. success will give you - Green solid, Blinking blue (solid mostly) and Red blinking.

Test your connection - Check under network for your client IP - should be the same range as the win 8 box. Pineapple Bar will load infusions.

* There are many varibles to your issue. help us help you with some more details if your require further help. Browser your using, OS your using, is your home router locked down? etc etc

now try with your browser - 172.16.42.1:1471

Link to comment
Share on other sites

Currently the Ethernet configuration is limited to Static only for use with Internet Connection Sharing from Windows (ICS) or Linux (wp5.sh).

I see you would prefer to provide your MK5 with an Internet connection over Ethernet. Typically this is achieved with a DHCP type connection.

While you can manually configure this from /etc/config/network it is not advised if you're not familiar with the inner workings of linux/openwrt.

That said, we do have an Ethernet Static/DHCP toggle feature slated for the next release which will be released by August 7th at the latest.

The change would look like this:

config interface lan
        option ifname   eth0
        option type     bridge
        option proto    dhcp
        option dns      8.8.8.8

As opposed to the default:

config interface lan
        option ifname   eth0
        option type     bridge
        option proto    static
        option ipaddr   172.16.42.1
        option netmask  255.255.255.0
        option gateway  172.16.42.42
        option dns      8.8.8.8

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...