Jump to content

Client Mode on Both Wireless Interfaces


Hamclock
 Share

Recommended Posts

I'd like to have my Mark V connect to 2 different wireless access points. In the web interface, it seems like you're forced into using wlan0 in AP mode, and only wlan1 can be used in Client Mode. I tried the following in /etc/config/wireless, but it didn't work:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option macaddr '00:13:37:a5:24:d1'
	option channel '1'

config wifi-iface
	option device 'radio0'
	option mode 'sta'
	option encryption 'psk2+ccmp'
	option network 'wan'
	option ssid 'Network1'
	option key 'Password1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option macaddr '00:13:37:93:5a:59'
	option channel '1'

config wifi-iface
	option device 'radio1'
	option mode 'sta'
	option network 'wan'
	option ssid 'Network2'
	option key 'Password2'
	option encryption 'psk2+ccmp'

I'd prefer to set this up through the web UI if possible, but if not, what do I need to change to get the config file to work properly?

Link to comment
Share on other sites

It will cause such a routing headache you realize this? Why would you like this setup?

Yea, most likely both wifi networks are on the 192.168.1.0/24 network, it's how 99% of home networks are set up. If they're not, then you're going to have to kill the dhcp server, then edit the routing tables so you can talk to both networks. Like Mr.P said, why would you want to cause this headache?

Link to comment
Share on other sites

It will cause such a routing headache you realize this? Why would you like this setup?

In my case, one network is in the 192.168.255.255 subnet, and the other is in 10.255.255.255. There will be no collisions. I'm well aware of how routing tables work, and I'd have no problems working with them if such an issue did come up.

Anecdotally, my home network mask is 192.168.0.255, so even if I were connecting to that and a more common 192.168.1.255, there wouldn't be issues.

Edited by Hamclock
Link to comment
Share on other sites

Ryan-Reynolds-But-Why.gif

In my case, one network is in the 192.168.255.255 subnet, and the other is in 10.255.255.255. There will be no collisions. I'm well aware of how routing tables work, and I'd have no problems working with them if such an issue did come up.

Anecdotally, my home network mask is 192.168.0.255, so even if I were connecting to that and a more common 192.168.1.255, there wouldn't be issues.

Link to comment
Share on other sites

I am pretty sure wlan0 is locked to karma only. If you want to connect client mode to multiple access points, the easiest solution would be to add a USB adapter and configure that with the wlan1 built in. Keep in mind there are known (hardware) issues with the throughput of the internal wlan1.

Link to comment
Share on other sites

Ryan-Reynolds-But-Why.gif

I've got a wireless-only network that'll be in the 192.168.255.255 range, and another wireless-only network (the 10.255.255.255) that's totally isolated. I also have a non-wireless-capable (Ethernet only) device that needs access to both networks. I'd like the Pineapple to serve as a bridge between the three; this struck me as something that should be fairly simple.

Link to comment
Share on other sites

I am pretty sure wlan0 is locked to karma only. If you want to connect client mode to multiple access points, the easiest solution would be to add a USB adapter and configure that with the wlan1 built in. Keep in mind there are known (hardware) issues with the throughput of the internal wlan1.

I'm aware of the hardware issues. When you say wlan0 is locked to Karma, do you just mean through the web UI? Surely a device like the Pineapple couldn't be -- dare I say -- locked down? A wireless interface is a wireless interface.

I've got no problem editing config files by hand, but my initial attempts at using wlan1's settings on wlan0 in /etc/config/wireless weren't met with much success.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...