Jump to content

TX-Power on newer FW


Mr.miYagi
 Share

Recommended Posts

Hi all

I have 3 Pineapples that (was) working very well.

As i booted the pineapples for the first time i got 27dBm on both radios wlan0/wlan1.

But after a few FW updates, the TX-power of wlan0 was restricted to 18dBm. I tried to change my location to BO, but no chance to get wlan0 over 18dBm.

iw reg get - gives me BO and up to 30dBm, but wlan0 is locked to 18dBm. wlan1 works fine up to 30dBm.

I tried to remove the lock, trough this:

https://forums.hak5.org/index.php?/topic/29082-signal-boosting/

With no increase.

Several people here and in the openwrt forums, ar claiming about it. But nobody has posted a working solution as i can see.

Somebody has a solution? @ 18dBm the pineapple is very low...

Several threads about that:

https://forums.hak5.org/index.php?/topic/30889-set-txpower-on-boot/

https://forums.hak5.org/index.php?/topic/25935-signal-booster-with-mark-iv/

https://forums.hak5.org/index.php?/topic/30748-txpower-woes/

http://pastebin.com/JcGhBBFJ

Tried all. No succes.

Seems a common problem...

Edited by Mr.miYagi
Link to comment
Share on other sites

Same problem here.

root@Pineapple:~# iwlist txpower
wlan1     unknown transmit-power information.

          Current Tx-Power=29 dBm  	(794 mW)

wlan0     unknown transmit-power information.

          Current Tx-Power=18 dBm  	(63 mW)
config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11ng'
	option macaddr '-------------'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option country 'BO'
	option txpower '29'
	option channel '5'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Some_network'
	option key '-------------'
	option encryption 'psk2+ccmp'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option macaddr '-------------'
	option channel '1'
	option country 'BO'
	option txpower '29'

config wifi-iface
	option device 'radio1'
	option mode 'sta'
	option network 'wan'
	option ssid '-------------'
	option key '-------------'
	option encryption 'psk2+ccmp'

https://forums.hak5.org/index.php?/topic/32489-cant-get-wlan0-over-13dbm-tx-power/ - really?

Edited by Morf
Link to comment
Share on other sites

So I read the above, and the link Yaba provided to the other thread, and I'm afraid I don't understand why wlan0 was locked to 18dbm, and is still locked down.

If it's a US regulation issue, why does wlan1 produce 27dbm?

Seb's comment in the other thread from Dec 2013 threw me for a loop however:

We have the atheros locked right now. We decided to swipe the next firmware unlocked though.

I'm not sure how to process that to be honest.

I'm just a simple guy...maybe Seb or Darren can explain what's going on with the Atheros and the 18dbm lockdown specifically? I'm sure there's a logical and reasonable explanation, but now my curiosity is piqued along with you all.

Link to comment
Share on other sites

I was searching for that quote by Seb the best part of 20 mins, was starting to believe I was mistaken. Good observation regarding the other chipset. Possibly a quality issue? The question has come up multiple times but still no official word, would be nice to see this answered either way.

Link to comment
Share on other sites

Hi guys,

I think I can explain what is going on.

First of all, what you need to know about my earlier statements is that we did indeed remove the country specific lock on every radio - at least in the software. This means that by changing the REG settings on your WiFi Pineapple you can use channels such as 14. It also means that theoretically you are able to adjust the TX power over the default limit.

Now what we didn't know at the time is that the actual HARDWARE is set to it's max TX power (or the legal max anyway).

I don't have any numbers for what the actual power output of the two cards is, but I can tell you that the software readout is possibly plain wrong.

The reason some of you were able to "change" the tx power using some hacks before was just that the software thought it could go higher than it actually could. Seeing as the hardware is locked though, on the newer firmwares it stays at the level it reports.

This is, to my knowledge what is going on. Seeing as I'm just the software guy, I don't know more than the above.

Best Regards,

Sebkinne

Link to comment
Share on other sites

Hi Seb

Thanks for explanation.

But i think it must be locked 'more'.

Since you cant move up or down with the dBm. Also with the mW.

Cant go even lower than 18dBm

If the SW is reading correctly now, means that the AR9331 chipset has a maximum of 18dBm? On the openwrt forums, i saw them putting over 20dBm, And finally, there is a big difference between the wlan0 and wlan1 output power, with the same SW.

wlan1 unknown transmit-power information.

Current Tx-Power=29 dBm (794 mW)

wlan0 unknown transmit-power information.

Current Tx-Power=18 dBm (63 mW)

on openwrt Forums:
Yes, the AR9331 soc chip is at 20dbM, check qulcomm's product page.
Jow's patch...

https://forum.openwrt.org/viewtopic.php?id=50209

Edited by Mr.miYagi
Link to comment
Share on other sites

Now what we didn't know at the time is that the actual HARDWARE is set to it's max TX power (or the legal max anyway).

I don't have any numbers for what the actual power output of the two cards is, but I can tell you that the software readout is possibly plain wrong.

Seeing as the hardware is locked though, on the newer firmwares it stays at the level it reports.

I'm still a bit confused. So.... You are telling us that that there are a few options like:

- AR9331 radio is locked and nobody really know this because it gives fake readouts

- AR9331 is operating at >18dBm power after changing REG but it gives fake readouts and nobody know its "true" tx-power

- AR9331 cannot go >18dbm because factory limit

Which of these is closest to truth? Because in every YT video of MKV there are "two powerful unlocked radios" and now we have one powerful unlocked radio and one 10x weaker...

Link to comment
Share on other sites

Slightly confusing issue. Hope this is not another hardware bug... there are no more spare USB ports after using a USB wireless card to circumvent the client mode throughput issues! :dry:

Anyway, looking at p311 of the AR9331 spec (if I'm reading it correctly) then around 18dbm is the typical power output for the transmitter - I'd guess it physically can't go much higher than this.. hopefully I'm wrong.

Link to comment
Share on other sites

Hey Seb,

Interesting, and sounds plausible. Just to cover all bases, did you try jow's hack over from openwrt? http://luci.subsignal.org/~jow/reghack/

The reghack utility replaces the regulatory domain rules in the driver binaries
with less restrictive ones. The current version also lifts the 5GHz radar
channel restrictions in ath9k.

This version is made for current OpenWrt trunk. To patch older release like 12.09,
use http://luci.subsignal.org/~jow/reghack/old/ .

How to use:

ssh root@openwrt

On ar71xx:

cd /tmp/
wget http://luci.subsignal.org/~jow/reghack/reghack.mips.elf
chmod +x reghack.mips.elf
./reghack.mips.elf /lib/modules/*/ath.ko
./reghack.mips.elf /lib/modules/*/cfg80211.ko
reboot

On mpc85xx:

cd /tmp/
wget http://luci.subsignal.org/~jow/reghack/reghack.ppc.elf
chmod +x reghack.ppc.elf
./reghack.ppc.elf /lib/modules/*/ath.ko
./reghack.ppc.elf /lib/modules/*/cfg80211.ko
reboot


Edit: Just a quick note that I forgot to mention, a couple of people were able to reach 20 dBm max with this, that appears to be the final limit. It was a mixed bag from the forum posts, some say it had no impact, others it worked. It may very well be what Seb was suggesting, and the software output isn't the actual.

Edited by mw3demo
Link to comment
Share on other sites

Screen Shot:

W2lTQ0Q.png

The only reason wlan0 is at 18 for me is because you need to turn disabled the interface before you can change the TX Power and then re-enabled the interface wlan1 was disabled thats why my TX Power shows 27

im not sure if the TX power can go beyond 27dbi i've never seen my Alfa Network AWUS036H go over 27 dbi

------

Uhhh not sure i get what some of you are talking about im able to get the TX power up to at least 27 dbi i'll see if i can get a screen shot of it i'll have to power up my pineapple real fast reason i was trying the TX power was as i said in another topic the signal i thought was kinda low for the pineapple with the antenna's it had which is kinda true if your not in-line with where the pineapple is i might be wrong thou.

Edited by ZaraByte
Link to comment
Share on other sites

Eh i just noticed you guys were talking about wlan0 not being able to increase the TX power i need sleep bad lol.

Link to comment
Share on other sites

Ok, then is it possible with karma-ng, (or the new karma coming) could we at least be able to set wlan2 to be the AP?

That seems to be our only option, other than purchasing an amplifier.

Edited by xrad
Link to comment
Share on other sites

Just saw this post by RMerlin over on smallnetbuilder that may be related:

Quote:
Originally Posted by Islandhitman viewpost.gif
Will Asuswrt-Merlin change this setting so it can be adjusted higher than 80mW? we do not have the same restrictions as the USA for the power level.
No. And expect this to become the norm in the future for other routers as well.

Thanks to the FCC, Asus will be forced to actually encrypt part of the wireless code to prevent end-user tampering. This is actually a REQURIEMENT from the FCC now. Manufacturers are required to ensure that end-users cannot change wireless behaviour or their regulation region through software modifications.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Link to comment
Share on other sites

The power really is restricted atm sadly. I've tried adjusting it but it never changes according to iwconfig. I also get lower signal strength on my tablet while sitting 2 feet from the pineapple than I do from outside the house to my real wifi router. So it isn't just an interface glitch, it really is running super low power. It does seem to be a new issue however. I bought my pineapple back in January, never had these problems till now. I did set it aside for a couple months though, so when the change came I do not know. But I noticed it immediately after doing the firmware update.

Link to comment
Share on other sites

Just saw this post by RMerlin over on smallnetbuilder that may be related:

That is just fucking depressing.

Sooooo sick of these taxdollar-funded alphabet agencies....all of them....so useless....but I digress....

Thanks for the info man. On a positive note, I'm guessing resellers of WiFi Gear in Bolivia's are in for a booming international business very soon. ;)

Link to comment
Share on other sites

  • 3 weeks later...

Hi Darren and co.

It would be nice to hear something official about that.

In the Episode "how-to-build-a-wifi-link" you describe that the wlan0 can go up to 24dbm.

And this is in the description:

What's really nice with the WiFi Pineapple Mark V is that these commands can be put together as a boot mode using the DIP switches. What's more since the Mark V has two radios on one board we're able to have the best of both worlds. Our Radio0 can be set to 24 dBm and attached to a 24 dBi gain antenna for the point-to-point link, while our Radio1 interface can be set to 30 dBm with a 6 dBi gain antenna for point-to-multipoint.

So it would be nice to hear why so many peoples are not able to reach this.

Thanks

Edited by Mr.miYagi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...