Jump to content

Programming Mark IV with Raspberry Pi


Datanet
 Share

Recommended Posts

I'm waiting for a uart programmer as the hakshop was out and I'm trying to use my Raspberry p instead. I have Tx, Rx and Gnd connected and have edited the cmdline and innittab files.
I get data over minicom but its all scrambled.

Baud is set at 115200, stop bits is 1, 8Bits.

I also ran a test by connecting the Pi's Tx and Rx together to send some text and it worked. Any ideas?

I've tried with different Bauds and also 7 bits.

If you've successfully flashed an Alfa AP121U with a Pi, I'd be interested in your experience.

EDIT: I managed to get it programmed with an Arduino Uno.

But I am still curious as to why it didn't work on my Raspberry Pi.

Edited by Datanet
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...