Jump to content

Experiences trying to self-build the MkV software


cooper
 Share

Recommended Posts

I'm following the build guide to the letter (for now) to see how far this'll bring me and some things don't pan out as well as they should. I figured I'd make a topic to keep track of things so that either the build guide, de code drop or both can be improved.

Some caveats:
1. I'm using a Gentoo Linux system rather than Ubuntu. That means some commands will be different for me and certain packages might be available under a diffent name or simply not at all.
2. Even though my machine is 64-bit capable, I have software that requires 32-bit (DAMN YOU SKYPE!) and just couldn't be arsed to go multilib. End result is that i'm running a 32-bit system.

Here we go.

Prerequisites - SKIPPED. Due to caveat 1 I'm just going to do absolutely nothing here, wait for stuff to break and then figure out what's missing. Since on Gentoo you always compile everything on the system from source there's a very decent chance I already have everything that's needed.

Download and extract - OK
Adding software feeds - SKIPPED. Since I'm behind the company firewall right now and accessing SVN and GIT over an HTTP proxy is a nuisance I'll just leave things as they came.
Adding custom files - SKIPPED. As I'm not adding any software I see no need to add anything else.
Preparing the build - ERROR=>SOLVED. The scripts/config folder contained 64-bit binaries that I can't run on my system. A quick "make clean" here removed the binaries and during subsequent steps things got rebuilt in a way that doesn't clash with my system.
Compiling the firmware - ERROR=>SOLVED. A x86_64-pc-linux-gnu host triplet was being used throughout which, again, claims the build system is 64-bit when in fact mine isn't. I fixed this by removing the tmp folder and recreating it again (there were quite a number of hidden files in there). I then restarted from the 'Preparing the build' stage.

Since I couldn't access a GIT repo I fetched mtd-utils-1.4.5 from their ftp. I'd like to note that this specific version is getting to be rather ancient...

This problem came up a couple more times so I've found an http mirror and another http mirror and one more that combined seem to have everything ready to go. Downloaded files to into the MK5/dl folder.

Building has since completed and I have a bin file, ready to move onto the Pineapple. Interesting fact: According to the 'file' program *ALL* executable binaries and libraries in the 'build_dir' dir are reported as having "corrupted section header size" very much UNlike the binaries in the 'staging_dir'. I'm assuming it's a product of some aggressive space saving going on prior to transferring the lot onto the Pineapple. I got the same response back from the file program when I pulled an executable from a stock pineapple running the 1.4.1 firmware onto my SD card to compare against cross-compiled fio binary.

When I get home I'll try to plonk the created bin file on the Pineapple and see how she fares....

Edited by Cooper
Link to comment
Share on other sites

Bricked it! :lol:

Followed the instructions to the letter, put the bin on an SD card, mounted it on the other end, ran sysupgrade -n /mnt/*sysupgrade.bin after which it went into single-user mode and said it was updating the firmware via STDIN followed by [w] which I ignored for a couple of minutes but since I didn't see anything after that for a few minutes I figured maybe they _want_ me to do something? It's typically how a question gets formulated:

Do you want to do something? [y]

So I hit the return button, the cursor jumped down a line and stayed there... After a few seconds [w] reappeared again so I just left it at that but shortly thereafter it said it was going to reboot. After reboot the Mk5 settled on simply having the green light on - nothing else. Power off/on same result.

Good thing this device has a safety net.

Link to comment
Share on other sites

Well, I followed the unbricking instructions and got it back to 1.4.1 in record time, to fight another day. I'll be having a long weekend off starting thursday so I'll probably have another go then.

Link to comment
Share on other sites

Hopefully I'll get some spare time to work through the build process too. I also want to diff against the openwrt code and see what has actually been changed for the MKV from stock openwrt.

Also, having a random snapshot in time doesn't really help much as this could get out of sync really quick.

For instance, come 1.4.2, what had changed? Firmware? Web interface? Both? How frequent are core firmware changes vs web interface changes? We don't have much transparency still.

If, like suggested above, LEDs aren't setup how do you at them up? How do you go from the firmware to a release a downloaded?

Still a fair few unanswered questions to resolve...

Link to comment
Share on other sites

Might I recommend a serial adapter. =)

You get one in stock and I'll consider buying one. :smile:

(and while you're at it, there's been a number of reports on this forum from people saying that their ducky orders were cancelled because it too is out of stock)

I'm now looking at a few webshops that sell these and they all come with a full RS-232 port and no easy cables. I could get creative with a serial cable and some connectors, but being the lazy type (I am, after all, a software developer) I'd rather just shove some money somewhere in exchange for a clean solution.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...