Jump to content

Wifi Pineapple Stuck on BLue led


Recommended Posts

I just received my pineapple and to my disappoint I have had problems right out of the box. When I received the pineapple I followed the instructions exactly as told, I inserted the sd card and waited what was suppose to be 5 minutes turned into 25min. After 25min. the pineapple was stuck with a Green, blue, and red led for about an hour. So I unplugged it and tried again and now it has been stuck on the blue led for a half hour. Any ideas on what I should do? But fireware flash or corrupted image on sd card perhaps?

Link to post
Share on other sites

If you haven't yet bought a fast class 10 sd card, you might want to run and get one.

The reason being, the sd cards they send may have issues.

But if you can't try to unbrick/flash it.

https://wifipineapple.com/?flashing

I can't even get the ethernet to work. Just sits at the blue LED and my pc says ethernet unplugged. Very disappointed. I would expect after paying $200 that they would send working equipment.

Link to post
Share on other sites

Well, hang on, if they used the higher end sd cards, the pineapple would cost more.

They are keeping the cost down as much as they can.

Don't fret it too much, no matter what you are going to learn a lot about your pineapple, it may not seem that way now but you will.

These guys are a small team, but so far from my experience, they really do care about their customers.

They are not going to leave you stuck with a product that doesn't work.

With as fast as Sebkinne updates, you may as well now start learning how to unbrick and flash.

Follow the instructions for unbricking with firmware 1.2.0, in the link I gave you, chances are you will be able to connect. Make sure you set the dip switches the way it says.......very important.

There are tons of help here, and half the fun is learning.

The main thing is to remember if you need any help, don't hesitate to ask.

Someone will help.

Edited by xrad
Link to post
Share on other sites

Well, hang on, if they used the higher end sd cards, the pineapple would cost more.

They are keeping the cost down as much as they can.

Don't fret it too much, no matter what you are going to learn a lot about your pineapple, it may not seem that way now but you will.

These guys are a small team, but so far from my experience, they really do care about their customers.

They are not going to leave you stuck with a product that doesn't work.

With as fast as Sebkinne updates, you may as well now start learning how to unbrick and flash.

Follow the instructions for unbricking with firmware 1.2.0, in the link I gave you, chances are you will be able to connect. Make sure you set the dip switches the way it says.......very important.

There are tons of help here, and half the fun is learning.

The main thing is to remember if you need any help, don't hesitate to ask.

Someone will help.

I tried following those instructions and I still can't get it to connect. It still just stays with a solid blue led. I check the interfaces on my laptop and the ethernet status is unplugged. I am going to try to swap sd cards.

Update: didn't help at all still stuck at Solid green and blue led. I even tried the factory reset dip switch combination

Edited by buckboy223
Link to post
Share on other sites

have you tryed using a new sd class 10

you did a factory reset

with the sd

when mine did it the sd was the issue corrupt drive new sd flashed withnot a issue

as xrad said its all about learning and this forum is packed with knowlage

Link to post
Share on other sites

Here you go buckyboy223......like m40295 it's most likely your card.........read through that thread.

https://forums.hak5.org/index.php?/topic/31667-answers-to-common-questions/

Your going to need one anyway, go grab you one, even if its a 4gb or 8 gb......class 10......... Bestbuy has 2 types of 8 gb that are the same, but in a different package, but one or the other are always on sale.

Edited by xrad
Link to post
Share on other sites

Here you go buckyboy223......like m40295 it's most likely your card.........read through that thread.

https://forums.hak5.org/index.php?/topic/31667-answers-to-common-questions/

Your going to need one anyway, go grab you one, even if its a 4gb or 8 gb......class 10......... Bestbuy has 2 types of 8 gb that are the same, but in a different package, but one or the other are always on sale.

I just went out and tried that and the same result solid green and blue led. I have tried factory resets multiple times but it wont even reset. It is literally stuck with a solid green and blue led not matter what I do. the checksums match the firmware. I cant understand what is going on unless something is physically broken with the device during shipping but I doubt that.

Edited by buckboy223
Link to post
Share on other sites

If all else fails, send the hakshop an email, they will exchange it.

Maybe try to format the sd on your computer......ext4......

If you only have Windows...... I'll let you know what I use......I can't remember what the name of it is.

I won't be able to for about an hour though.

Link to post
Share on other sites

Yeah don't copy the files to the sd......from the flashing page ;

Do this.....

"Unbricking a bricked WiFi Pineapple MKV

Bricked your WiFi Pineapple MKV? Unbricking is easy and doesn't require any extra hardware!

Download the special factory image. This image is the WiFi Pineapple MKV's 1.2.0 firmware, packaged differently to allow unbricking. Please verify it's md5 checksum to be 167b1533b9dd5c49f7107413fb960bfa.

Power off your WiFi Pineapple MKV and set the DIP switches to up, up, up, up, down (from left to right).

Connect to your WiFi Pineapple MKV via ethernet and set your network interface to a static IP of 192.168.1.2

Boot up the WiFi Pineapple MKV. After around five seconds, you can navigate to http://192.168.1.1

Upload the factory-1.2.0.bin file through the interface. Wait for it to complete.

Set all the DIP switches back to the default configuration up, up, up, up, up (from left to right).

Make sure the SD card is inserted and powercycle the WiFi Pineapple MKV. Your device will now boot the 1.2.0 firmware. Please wait patiently and refer to the first boot instructions in your WiFi Pineapple MKV instructions. You may skip any information relating to the stager.

You are done. Enjoy your freshly flashed WiFi Pineapple MKV!"

For me that works

Edit: link to factory image

https://wifipineapple.com/mk5/factory-1.2.0.bin

...

Edited by xrad
Link to post
Share on other sites

Yeah don't copy the files to the sd......from the flashing page ;

Do this.....

"Unbricking a bricked WiFi Pineapple MKV

Bricked your WiFi Pineapple MKV? Unbricking is easy and doesn't require any extra hardware!

Download the special factory image. This image is the WiFi Pineapple MKV's 1.2.0 firmware, packaged differently to allow unbricking. Please verify it's md5 checksum to be 167b1533b9dd5c49f7107413fb960bfa.

Power off your WiFi Pineapple MKV and set the DIP switches to up, up, up, up, down (from left to right).

Connect to your WiFi Pineapple MKV via ethernet and set your network interface to a static IP of 192.168.1.2

Boot up the WiFi Pineapple MKV. After around five seconds, you can navigate to http://192.168.1.1

Upload the factory-1.2.0.bin file through the interface. Wait for it to complete.

Set all the DIP switches back to the default configuration up, up, up, up, up (from left to right).

Make sure the SD card is inserted and powercycle the WiFi Pineapple MKV. Your device will now boot the 1.2.0 firmware. Please wait patiently and refer to the first boot instructions in your WiFi Pineapple MKV instructions. You may skip any information relating to the stager.

You are done. Enjoy your freshly flashed WiFi Pineapple MKV!"

For me that works

Edit: link to factory image

https://wifipineapple.com/mk5/factory-1.2.0.bin

...

yes, I understand but that does not work either. As stated in previous posts the ethernet is not connecting when trying that. I have already attempted said method about 13 times now. I just tried again and found I have to plug the ethernet in and then out then half way for it to even somewhat connect. So I am pretty sure something is physically wrong with the device.

Link to post
Share on other sites

Yup......you have tried everything I know to do. Sorry...

Send the hakshop an email tonight.....it might take a day or so (business days M-F) for them to get back to you.

Will do... thank you for your patience and help with troubleshooting though.

Link to post
Share on other sites

buckboy223, sorry the pineapple hasn't been behaving well. Please contact the hakshop and we'll get you sorted at no additional cost ASAP.

For anyone else experiencing these issues:

1) If the card reads in your computer it's most likely good. The cards we ship are sort of basic get-you-started cards for the purpose of firmware loading and standard setup and should work for most use cases - it's not until you start doing logging or hosting large sites that you'll need to upgrade.

2) If the card files on the card are bad you'll get the amber blinking on first boot. Format the card, copy the factory files over and try again.

3) Now, if you can't get into recovery mode from the DIP switches - THEN we have a problem. Let us know and we'll make sure we get you up and running.

Link to post
Share on other sites

Hi i would just like to say how amazing Hak5 is

i had a problem with my WP MK5 and i emailed them at the Hakshop and 2 days later i get an email saying that a replacement is on its way,

I have to say that is the best customer service i have ever received.

I will continue to love you guys and i think what you are doing is great

Link to post
Share on other sites

Something similar happened to me, with the green, blue and red LED's. What was causing mine was insufficient power from the replacement cable I had bought. I had bought it from a different vendor. Also can occur if your laptop does not have enough voltage to supply the pineapple through USB. I was using a USB to barrel connector cable.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...