Jump to content

Brand New Mark V not Mounting any SD cards


Recommended Posts

Hi Guys

I think my Pineapple that was delivered on wednesday is faulty, im not able to get the SD card to mount on the device at all
iv tried a brand new 4G and 32G card however if i use an external USB memory card reader plugged in to the device it works correctly.
out put from mounted Drives
Filesystem Size Used Available Use% Mounted on
rootfs 3.8M 448.0K 3.4M 11% /
/dev/root 11.3M 11.3M 0 100% /rom
tmpfs 30.2M 124.0K 30.1M 0% /tmp
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock3 3.8M 448.0K 3.4M 11% /overlay
overlayfs:/overlay 3.8M 448.0K 3.4M 11% /
/dev/sdb1 3.7G 121.5M 3.4G 3% /sd <--- This Device is mounted via a USB>SD Card Reader
I have modified the FSTab to allow for me to add infusions to the USB SD card reader however this is not ideal
I Ran fdisk and other then the MTDBlocks this is all that shows up. again the sdb is plugged in to the SD card reader
root@Pineapple:~# fdisk -l
Disk /dev/sdb: 3965 MB, 3965190144 bytes
49 heads, 48 sectors/track, 3292 cylinders
Units = cylinders of 2352 * 512 = 1204224 bytes
Device Boot Start End Blocks Id System
/dev/sdb1 4 3293 3868160 b Win95 FAT32
root@Pineapple:~#
Out of the Logs i can see what i think it the SD card attempting to load via sg0 ??
but i cannot cd to /dev/sg0
May 16 07:11:10 Pineapple kern.notice kernel: [ 615.450000] sd 2:0:0:0: [sda] Attached SCSI removable disk
May 16 07:11:10 Pineapple kern.notice kernel: [ 615.090000] sd 2:0:0:0: Attached scsi generic sg0 type 0
May 16 07:11:10 Pineapple kern.notice kernel: [ 615.090000] scsi 2:0:0:0: Direct-Access Multi Flash Reader 1.00 PQ: 0 ANSI: 0
May 16 07:11:09 Pineapple user.notice usb-modeswitch: 1-1.4:1.0: Manufacturer=Generic Product=Mass_Storage_Device Serial=058F0O1111B1
May 16 07:11:09 Pineapple kern.info kernel: [ 614.090000] scsi2 : usb-storage 1-1.4:1.0
Which appears that the Disk is attempting to mount but cannt ??
or am i looking in the wrong direction.
if the device is faulty then id like to send it back for a replacement device as its only 3 days old and has not worked from the moment it arrived
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

Created by ten thousand monkeys on typewriters it's not Shakespeare but it will do
Link to comment
Share on other sites

You don't mount SCSI-Generic devices. You mount drives.

Since fdisk can tell you what the partition table on the card is, neither the card nor the reader are faulty in any obvious way.

The 'fdisk -l' command tells you the drive device is /dev/sdb1 so try mounting that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...