Jump to content

GNURadio LIVE -- install to hard drive?


Recommended Posts

Well, I've been playing with the gnu radio live DVD for a while now, and decided that it might just be easier for me to install the thing on a spare laptop... so I looked for an 'install' option but never found one.

On a whim, I decided to use 'sudo dd if=/home/me/gnu.iso of=/dev/sda' to simply throw the image on the laptop hard drive... this was done with a differ computer, of course. I've never tried to write an image directly to a hard drive, so this was sort of an experiment for me. The end result was a bootable gnu radio laptop hard drive. Everything was awesome until I realized what I should have thought of before I started..... the image written to the hard drive was only 2GB. Since I've never done this technique before, I have no idea how to make the system utilize the entire disk (instead of only 2GB).

Does anyone have any suggestions or resources that would tell me how to either resize the .iso to allow more space... or resize the hard drive to allocate more space?!? As a side note, disk utilities do not show a valid partition table due to the image making the hard drive look like a CDROM (live CD).

I'm stumped. Any suggestions? Thanks!

Link to comment
Share on other sites

Boot a machine with the target hd as a slave and the dvd in the dvd drive.

Fdisk the hd, recreate the target partition (allow some swap space too if you like) and mark it as bootable.

Format the destination drive with the appropriate fs and size.

Mount dvd drive and harddisk somewhere.

cp -a /mnt/dvd/* /mnt/hd

All that's left is the bootloader. If on boot of the dvd a prompt appears, presumably briefly, try tabbing to see what options exist. You might get away with "<optionname> root=/dev/hd<devicenum>"

Otherwise, boot the dvd normally then work the hopefully still present lilo or grub config file such that it points to the hd and make it write itself to the device.

That should be everything...

Link to comment
Share on other sites

Cooper, everything worked like a charm... Except I have no idea how to change the boot parameter. I tabbed upon boot and got to the 'Boot Options' which allows me to type on a line that says:

file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --

Are these the boot loading options you were talking about, and should I just type 'file=/dev/sda1/' ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...