Jump to content

Karma Alternative - Could it work?


KronicTec
 Share

Recommended Posts

Hi Guys Ive been playing around with the karma around shopping centres etc... and as we all know it doesnt seem to work well on new android and iphones post 2012... however if there are known wifi points that people have previously connected to and creating an interface with the same name on the pinapple usually results in a connection with new phones as well.

Also have found its possible to create multiple access points off the one radio with unique ssids by adding entries into wireless config:

Snippet from /etc/config/wireless

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option encryption 'none'

option ssid 'SSID1'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'SSID 2'

option encryption 'none'

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'SSID 3'

option encryption 'none'

Soooo.....I was thinking would it be possible to read all the probe requests every n seconds from karma log and then create a new ssid programmatically via a shell script or php statement? I've found at the moment I'm limited to about 6 interfaces before the interface dies btw...

Link to comment
Share on other sites

Seems like taking the SSIDs found by Karma and sending them to a file that could be refreshed by the Occupinapple Infusion using the with MAC address option, so that they all get Internet if you're providing it, might achieve what you're describing. But that also seems like exactly what Karma does to begin with.

Link to comment
Share on other sites

You're almost half way there. It's an interesting issue. Also ironic re: Barry's sig. Couple that list with occupineapple and you have a dirty hack. There's a lot more to it and I don't want to give it all away as the cat and mouse game progresses - but you're on to the fact that karma can be augmented. Stay tuned.

Link to comment
Share on other sites

Hey Darren and Barry, thanks for the reply... Ive been experimenting with this a lot lately and this is getting very interesting... one thing you might be able to help with is on the occupinapple thing... you cant acctually join the ssids that occupinapple creates however that would be awsome to mess with people on the ssid they ended up joining.... I saw this post that uses airbaseng which I had a brief crack at but failed misserably.. what is the difference between airbase/dump/etc... ng and mdk3?

http://www.iodigitalsec.com/fully-automatic-wireless-hacking-station/ ---> if I was to get this to work would people acually be able to see the ssids that are being created?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...