Jump to content

android OTG adapter not working


brazen
 Share

Recommended Posts

I purchased the Exfiltrator ducky. I connected a usb keyboard (that shipped with my iMac) to my android phone with the OTG adapter that came with the ducky. I am not able to type with the keyboard. I even opened a terminal on the phone from an app icon and tried to type with the keyboard without success. I am ofcourse able to type on the android with my fingers, but not able to type from the keyboard.

HTC Sensation - did a check for updates and my "phone is up to date"

Android version 4.0.3

HTC Sense version 3.6

http://hakshop.myshopify.com/collections/usb-rubber-ducky/products/usb-rubber-ducky-exfiltrator

Link to comment
Share on other sites

I'm not sure how this is ducky related unless you are saying it does not work either. It is possible your android phone doesn't have support for it? Try using it on a Galaxy S3. That is the phone I have and most OTG cables work with a keyboard on it.

how is this ducky related? the otg adapter is what came with the ducky. I don't know if there is something wrong with: 1. the otg 2. my phone. 3. apple usb keyboard not compatible with phone? not sure. I purchased this here from hak5 so I thought I would ask at hak5 forums

Link to comment
Share on other sites

Try a USB Thumb drive to your phone instead of a keyboard. It should show up on your phone as storage. Try a friend's phone that is running newer OS of android as well? If all that still doesn't work contact shop@hak5.org with your order number and all the info you can give.

http://hakshop.myshopify.com/pages/refund-and-return-policy

Link to comment
Share on other sites

Plug in a keyboard. try that and if it doesn't work, then have a look online for USB keyboard support.

Edited by MB60893
Link to comment
Share on other sites

  • 2 weeks later...

The reason it's not working is because the HTC Sensation doesn't support USB Host unless you've rooted and installed a custom kernel... On top of that, the Sensation isn't able to power devices through it's micro USB port, so you'll need a powered USB hub or a powered USB OTG Y cable in order for the Ducky (or any other USB device) to work with your phone. Sadly, this is the case with many older Android devices, either they don't support USB Host at all (unless you use a custom kernel), or they're not able to provide power to whatever device you're trying to connect to your phone, so you'd need a USB OTG Y cable with an external power source, or a powered USB hub in order for it to work. Newer devices (that shipped with at least Android ICS 4.0.3 or newer) should have no issues, I say should because it's still not guaranteed to work even though Google added USB Host support in Android ICS and beyond...

Edited by d3v14n7
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...