Jump to content

Problems Connecting To Pineapple


OPCA_Acid_Lord
 Share

Recommended Posts

I am having problems connecting any device to my pineapple. I have Wlan0 and Wlan1 enabled, the pineapple connected to my home network (for internet access), karma off (with the 's MAC address blacklisted, AutoSSH off, Cron enabled, DNSSpoof disabled, and I am running the 1.0.4 firmware. Any suggestions? If I don;t have my settings correct, please let me know. Also, if more information is needed, post what I need to add in the reply box. Thanks. :D

Link to comment
Share on other sites

Sorry don't understand the question... How are you trying to connect devices (wlan0)? And how is the pineapple connected to your home network? Via Client Mode (wlan1)? If your device can see the default Access Point name the Pineapple is broadcasting or whatever you've renamed it, just select it like you normally would a wifi access point. Since it is an open/unencrypted network you'll get right on and the pineapple will assign your device an IP address...

Link to comment
Share on other sites

I don't know how to answer your first question. Sorry :( Yes, my pineapple is connected to my home network via Client Mode. I also have my pineapple connected to my computer via an Ethernet cable. My devices can see the Access Point, but they don't connect to it. I tried to connect to my pineapple with my MacBook air and my Galaxy Note 2 to test some phishing pages I created, but my MacBook just says "connection timed out" and my phone just says "saved" instead of "obtaining ip address" then "connected". Should I unplug my Ethernet cable, or does it matter?

Link to comment
Share on other sites

You aren't doing anything at this point that requires blacklisting.... When you get to using Karma you'll need to understand the difference between the two and implement in order to not Karma your own equipment but there are several posts here that cover that info. And I don't think you ever need to blacklist the pineapple itself as it is the one using Karma and it knows this.

Link to comment
Share on other sites

Ok that's a strange one... Since you can configure it and all I assume you can get to the management page via the ethernet connection. That means you should also be able to use ssh to get in. I would ssh into the pineapple and copy the /etc/config/wireless file contents into the forum here. You can use the spoiler tag to save us all the scrolling. With that we can rule out the setting of the Access Point.

The only other thing I can think of is that your other wireless devices all use static IP addresses instead of automatic/DHCP settings?

Other than those two things I don't know if I can help you...

Link to comment
Share on other sites

Here is /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:XX:XX:XX'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Pineapple5_1A60'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option macaddr '00:13:37:XX:XX:XX'
option channel '6'
config wifi-iface
option device 'radio1'
option mode 'sta'
option network 'wan'
option ssid 'NETGEAR87'
option key '%%NETWORK PASSWORD%%'
option encryption 'psk2+ccmp'

I blocked out part of the MAC address for my devices and the password for my internet. Just in case.
Edited by OPCA_Acid_Lord
Link to comment
Share on other sites

No problem... What firmware version are you using on your pineapple?

Someone else might want to see some system logs like a dmesg output to ensure your hardware is working correctly but everything you say indicates wlan0 is active as it should be. Do you have a Live Disk for a Linux distro lying around that you could boot your laptop from? Maybe see if that OS can use the hardware to connect to the Pineapple? I'm out of ideas...

Link to comment
Share on other sites

I am using 1.0.4. Unfortunately i don't, but I do have a Kali Linux iso that I can use in Virtual Box

Set your network adapter in the virtual machine to share your network card settings. When i run Vmware workstation i do not see my wireless adapters but they show up as eth0 and eth1 when i have no Ethernet attached. I checked the MACs and they were really wlan0 and wlan1 this might help some

Link to comment
Share on other sites

  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...