Jump to content

3g dongle mf637 connection problems 3/giffgaff uk.


Recommended Posts

Hi all,

Wondering if anyone can help, bit of a noob with this. Had a pineapple quite a while and had no problems so far, all working well.

Decided to try and get 3g working so bought a mf637 T-mobile branded dongle unlocked.

Using a script found on the forums I'm getting no joy at all and have no clue where to start.

Lsusb output doesn't show the dongle at all :


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 003: ID 0781:5571 SanDisk Corp. Cruzer Fit


When I unplug and put the dongle back in I see this in the logs:


00:02:52 Pineapple kern.info kernel: [ 172.570000] usb 1-1.3: new high-speed USB device number 4 using ehci-platform
00:02:52 Pineapple kern.err kernel: [ 172.620000] hub 1-1:1.0: unable to enumerate USB device on port 3


Did ls /dev/tty* to see if anything matches as defined in the script (/dev/ttyUSB0) but nothing along those lines is shown.

I tested my three 321 uk sim in the dongle on my laptop after filling in the apn and dial number settings and it connected ok, however not allowing me to browse (they new it was in a dongle and therefore not allowed!) guess Ill have to change sim. I'm guessing this wouldn't have anything to do with my problems would it.

Thanks for any info (script below)


*19d2:0031*) echo "ZTE MF637 (3UK) detected. Attempting mode switch"
uci delete network.wan2
set network.wan2=interface
uci set network.wan2.ifname=ppp0
set network.wan2.proto=3g
uci set network.wan2.service=umts
set network.wan2.device=/dev/ttyUSB0
set network.wan2.apn=three.co.uk
set network.wan2.defaultroute=1
uci commit network
10; rmmod usbserial
5; insmod usbserial vendor=0x19d2 product=0x0031
sleep 5; /etc/init.d/firewall disable; /etc/init.d/firewall stop
"3G: firewall stopped"
iptables -t nat -A POSTROUTING -s -o 3g-wan2 -j MASQUERADE
-A FORWARD -s -o 3g-wan2 -j ACCEPT
-A FORWARD -d -m state --state ESTABLISHED,RELATED -i 3g-wan2 -j ACCEPT

Link to comment
Share on other sites

  • 3 weeks later...

Fixed it, my bad. Problem was staring me in the face, unable to enumerate USB device on port 3!

Dongle was connected to powered usb hub via extension lead. Removed lead, directly connected, sorted. I've never had a USB extension lead that actually worked, they are next to useless.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...