Jump to content

Firewall kali linux


Recommended Posts


Ive port forwarded port 433 on my router, this has work fine as i have checked it with my vista box. Only when i turn my firewall off in vista that it will show as open. So when i assign thiskali's internal ip to this open port it still shows as closed. Found a tool called GUFW, gave this a go but still had no luck. Does anybody know have to turn off the firewall in kali?


Link to comment
Share on other sites

just for one boot, so i can turn it on and off as i like, Pretty new to all this so not realy sure if im doing this right, Found this topic,

For Linux such as Debian / Ubuntu / Suse Linux etc, type following commands(as root).
 First save firewall rules:
 # iptables-save > /root/firewall.rules
 # sudo iptables-save > /root/firewall.rules
 Second type the following commands :
 # iptables -X
 # iptables -t nat -F
 # iptables -t nat -X
 # iptables -t mangle -F
 # iptables -t mangle -X
 # iptables -P INPUT ACCEPT
 # iptables -P FORWARD ACCEPT
 # iptables -P OUTPUT ACCEPT

But when i check online to see if the port is open, it always shows as closed on my kali linux box, were am i going wrong?


Link to comment
Share on other sites

Thanks for the reply, but im still having trouble with this, When i turn off the firewall on my vista box its showing that port 443 is open. When i assigned the same local ip to my kali box, even when i use firestarter or Gufw its showing that the port is closed. Not got a clue with this one,,,, Anybody else having this trouble?

Link to comment
Share on other sites

there are a few reasons why a port may not be seen as 'open' from an external machine. The 2 major reasons why it may look closed are that !) the firewall is blocking the port of interest or 2) there is no application currently listening on that port. Try running $ sudo netstat -auntp | grep '443'

to see if anything is running on port 443

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...