Jump to content

Archived

This topic is now archived and is closed to further replies.

no42

Watching Planes on Linux

Recommended Posts

Software: git clone https://github.com/antirez/dump1090.git

Compile:

cd dump1090;make;make install

Simple execution/dump :

dump1090

Live feed:

./dump1090 --interactive

Unlike the Windows software, it can plot planes on a builtin http interface using Google Maps

./dump1090 --enable-agc --aggressive --net --net-http-port 8080

Then open your browser and go to http://127.0.0.1:8080 to watch planes fly above you.

Share this post


Link to post
Share on other sites

This looks like something I'll need to put on my "to do" list to play around with in the near future. Thanks.

Share this post


Link to post
Share on other sites

I just noticed that Kali has rtl_adsb installed, what do I need to install(or maybe it's already installed since I've don't know what to look for) to get a GUI frontend to use with rtl_adsb that's in Kali. Also, how to I start the rtl_adsb in Kali or will it auto-start when I open a GUI to watch planes.

Share this post


Link to post
Share on other sites

I just noticed that Kali has rtl_adsb installed, what do I need to install(or maybe it's already installed since I've don't know what to look for) to get a GUI frontend to use with rtl_adsb that's in Kali. Also, how to I start the rtl_adsb in Kali or will it auto-start when I open a GUI to watch planes.

I used the above software, had to install a couple usb libs, it will tell you what you need when it errors out on the first make.

Share this post


Link to post
Share on other sites

So how do I use it? When I click on it it simply opens up a Terminal with some info. How do I start it or what kind of GUI do I need to use with it to do what they did on Hak5 Ep.1525? I'd love to "tune in" and see what's going on at my small, local airport. I think that'd be a hoot.

Share this post


Link to post
Share on other sites

You can also try http://www.irrational.net/2012/08/06/tracking-planes-for-20-or-less/ but I gave up, as i was having some gnu radio version problems.

So decided to stick with dump1090 - its easy peazy!

If you get a chance you really need to give Kali Linux 1.0.6 a look and see all the SDR software that's pre-installed. I just noticed the rtl_adsb stuff today and just wonder how I'd use it or what else I need to get my Plane Tracking up and running. I'm sure if they've got that on there they have to have some other stuff so that you can actually use it, just don't know where to find it.

Share this post


Link to post
Share on other sites

So how do I use it? When I click on it it simply opens up a Terminal with some info. How do I start it or what kind of GUI do I need to use with it to do what they did on Hak5 Ep.1525? I'd love to "tune in" and see what's going on at my small, local airport. I think that'd be a hoot.

Start it up, then hit 127.0.0.1:8080 in a browser.

Share this post


Link to post
Share on other sites

Start it up, then hit 127.0.0.1:8080 in a browser.

Ok, now see, that helps out a ton. I didn't know I had to go into my browser to see stuff. Thanks, I'll give it a try.

Ok, that didn't work. Wonder if it's some other IP address?

I open up rtl_adsb and I get these options.

rtl_adsb: invalid option -- 'h'

rtl_adsb, a simple ADS-B decoder

Use: rtl_adsb [-R] [-g gain] [-p ppm] [output file]

[-d device_index (default: 0)]

[-V verbove output (default: off)]

[-S show short frames (default: off)]

[-Q quality (0: no sanity checks, 0.5: half bit, 1: one bit (default), 2: two bits)]

[-e allowed_errors (default: 5)]

[-g tuner_gain (default: automatic)]

[-p ppm_error (default: 0)]

filename (a '-' dumps samples to stdout)

(omitting the filename also uses stdout)

Streaming with netcat:

rtl_adsb | netcat -lp 8080

while true; do rtl_adsb | nc -lp 8080; done

Streaming with socat:

rtl_adsb | socat -u - TCP4:sdrsharp.com:47806

So I type in "rtl_adsb start" then hit enter and I get this

Found 1 device(s):

0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: ezcap USB 2.0 DVB-T/DAB/FM dongle

Found Rafael Micro R820T tuner

Tuner gain set to automatic.

Tuned to 1090000000 Hz.

Sampling at 2000000 Hz.

Exact sample rate is: 2000000.052982 Hz

So rtl_adsb is on. Now I just need to figure out how to get it to some kind of GUI so I can see it?

Share this post


Link to post
Share on other sites

Are you running the command from the dump1090 folder? I found that moving the binary to /usr/lib/ actually breaks it. If you run the command from the folder it works.

dump1090.png

Share this post


Link to post
Share on other sites

think he is still trying to figure out rtl_adsb?

Share this post


Link to post
Share on other sites

think he is still trying to figure out rtl_adsb?

LOL, I'm still trying to figure it all out. Ok, so when I open up the rtl_adsb terminal what do I need to type in since the two options look like NetCat or SoCat and I have neither. Do I just type "rtl_adsb start" and let it start? Also, by "folder" do you mean a folder in my browser and if so what do I call/lable it? Baby steps guys, baby steps. Thanks.

Share this post


Link to post
Share on other sites

LOL, I'm still trying to figure it all out. Ok, so when I open up the rtl_adsb terminal what do I need to type in since the two options look like NetCat or SoCat and I have neither. Do I just type "rtl_adsb start" and let it start? Also, by "folder" do you mean a folder in my browser and if so what do I call/lable it? Baby steps guys, baby steps. Thanks.

Follow the steps at the top of the thread. Don't worry about the make install part, it does nothing. From inside the dump1090 folder run the ./dump1090 --enable-agc --aggressive --net --net-http-port 8080 command. There's no need for the rtl_adsb commands. It will start scrolling what it's recieving, then you go to 127.0.0.1:8080 in your browser.

Share this post


Link to post
Share on other sites

So just install dump1090 and then run(in terminal??) ./dump1090 --enable-agc --aggressive --net --net-http-port 8080. Remember, you're talking to a guy who's been running Linux just a little less then a year and can do stuff in Terminal but can't do Bash scripts or much with compiling from source or other more complicated stuff yet. I'm learning but still not a Linux Master by any stretch of the imagination. LOL. That's why I said "baby steps", I know it bugs some folks but I really need it as simple as possible for this stuff please.

Share this post


Link to post
Share on other sites

So just install dump1090 and then run(in terminal??) ./dump1090 --enable-agc --aggressive --net --net-http-port 8080. Remember, you're talking to a guy who's been running Linux just a little less then a year and can do stuff in Terminal but can't do Bash scripts or much with compiling from source or other more complicated stuff yet. I'm learning but still not a Linux Master by any stretch of the imagination. LOL. That's why I said "baby steps", I know it bugs some folks but I really need it as simple as possible for this stuff please.

Yep, just follow the steps.

Share this post


Link to post
Share on other sites

I'm still not getting it. For Installation it simply said Type "make". and I know there's more to it then that. Isn't there some kind of git hub deal I need to type in to clone the app?

Ahh, or do I copy and past the line next to Software at the top? I'm slow but I think I'm starting to figure it out a little bit.

Share this post


Link to post
Share on other sites

Follow the steps at the top of the thread. Don't worry about the make install part, it does nothing. From inside the dump1090 folder run the ./dump1090 --enable-agc --aggressive --net --net-http-port 8080 command. There's no need for the rtl_adsb commands. It will start scrolling what it's recieving, then you go to 127.0.0.1:8080 in your browser.

Looks like the make install part does something because when I tried to run it I got this:

cd dump1090;make;make install

gcc -O2 -g -Wall -W `pkg-config --cflags librtlsdr` -c dump1090.c

Package librtlsdr was not found in the pkg-config search path.

Perhaps you should add the directory containing `librtlsdr.pc'

to the PKG_CONFIG_PATH environment variable

No package 'librtlsdr' found

dump1090.c:46:21: fatal error: rtl-sdr.h: No such file or directory

compilation terminated.

make: *** [dump1090.o] Error 1

make: *** No rule to make target `install'. Stop.

Also, as far as "librtlsdr" not being found. When I tried to install it I got this:

sudo apt-get install librtlsdr

[sudo] password for darrell:

Reading package lists... Done

Building dependency tree

Reading state information... Done

librtlsdr is already the newest version.

librtlsdr set to manually installed.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So it IS there, Dump1090 just doesn't see it I guess.

So, I've cloned Dump1090 from git hub, now I need to install it but can't. Where do "we" go from here?

Share this post


Link to post
Share on other sites

OK, so I have a "dump1090" folder in my home folder. I open it and I have this:

testfiles folder, tools folder, .git folder, ant.c, ant.h, dump1090.c, gmap.html, Makefile, README.md, TODO, .gitignore. Where do I "run" ./dump1090 --enable-agc --aggressive --net --net-http-port 8080 at, in Terminal or what?

Share this post


Link to post
Share on other sites

OK, so I have a "dump1090" folder in my home folder. I open it and I have this:

testfiles folder, tools folder, .git folder, ant.c, ant.h, dump1090.c, gmap.html, Makefile, README.md, TODO, .gitignore. Where do I "run" ./dump1090 --enable-agc --aggressive --net --net-http-port 8080 at, in Terminal or what?

Now you're in the land of finding dependencies!

Run this;

apt-get install librtlsdr-dev
then run your make command again.
A lot of times if you don't have the -dev files you can't compile software.

Share this post


Link to post
Share on other sites

Ok, got the .dev files installed and got this when I tried to do the make make install.

cd dump1090;make;make install

gcc -O2 -g -Wall -W `pkg-config --cflags librtlsdr` -c dump1090.c

gcc -O2 -g -Wall -W `pkg-config --cflags librtlsdr` -c anet.c

gcc -g -o dump1090 dump1090.o anet.o `pkg-config --libs librtlsdr` -lpthread -lm

/usr/bin/ld: cannot find -lusb-1.0

collect2: error: ld returned 1 exit status

make: *** [dump1090] Error 1

make: *** No rule to make target `install'. Stop.

So where do we go from here? looks like I need a "-lusb-1.0" file or some such but we do seem to be getting closer.

Share this post


Link to post
Share on other sites

Ok, got the .dev files installed and got this when I tried to do the make make install.

cd dump1090;make;make install

gcc -O2 -g -Wall -W `pkg-config --cflags librtlsdr` -c dump1090.c

gcc -O2 -g -Wall -W `pkg-config --cflags librtlsdr` -c anet.c

gcc -g -o dump1090 dump1090.o anet.o `pkg-config --libs librtlsdr` -lpthread -lm

/usr/bin/ld: cannot find -lusb-1.0

collect2: error: ld returned 1 exit status

make: *** [dump1090] Error 1

make: *** No rule to make target `install'. Stop.

So where do we go from here? looks like I need a "-lusb-1.0" file or some such but we do seem to be getting closer.

Yep, I'm pretty sure that's the last dependency you'll need.

apt-get install libusb-1.0-0-dev

Think that's the right one.... If it doesn't work, try

apt-get install libusb-dev

I should have written it down when I got it working the other day.

Share this post


Link to post
Share on other sites

That helped some, we are getting there one bit at a time. Now I get this:

gcc -g -o dump1090 dump1090.o anet.o `pkg-config --libs librtlsdr` -lpthread -lm

make: *** No rule to make target `install'. Stop.

so what's the next step(and probably the last step) to get dump1090 up and running? Also, thanks so much for all the help so far. Folks on this forum are pretty awesome where Linux is concerned.

Share this post


Link to post
Share on other sites

That helped some, we are getting there one bit at a time. Now I get this:

gcc -g -o dump1090 dump1090.o anet.o `pkg-config --libs librtlsdr` -lpthread -lm

make: *** No rule to make target `install'. Stop.

so what's the next step(and probably the last step) to get dump1090 up and running? Also, thanks so much for all the help so far. Folks on this forum are pretty awesome where Linux is concerned.

apt-get install librtlsdr-dev

No problem! Been running back and forth outside, just crashed my screaming pineapple in a tree.... Think it's broken until I can get a new motor, sheared the shaft off where the prop attaches... Damn trees.

Share this post


Link to post
Share on other sites

Already have it installed:

librtlsdr-dev is already the newest version.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

What's the deal with "*** No rule to make target `install'. Stop." What "rule" is the program looking for?

I have a feeling that we're not too far from getting it working. Just need to figure out what these "rules to make target "install" are and we'll be good to go.

Share this post


Link to post
Share on other sites

Ok, I'm going to give up on trying to watch the planes for now. I just tried to listen to my Gqrx SDR and got nothing. Somehow trying to get dump1090 installed borked my Gqrx so I deleted the dump1090 folder and I'll just wait for them to bring out a nice, simple .deb package to download and install. From what I see it's in the works. Thanks for the help.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...