Jump to content

SIOCADDRT: No such device problem


Daren_Z
 Share

Recommended Posts

Hello,

I've set up and installed a the wifi pineapple software on Ubuntu, but when I connect using sudo ./wp5.sh, and go through the menu, I get an error message that looks like this:

Screenshotfrom2014-01-28231457_zpsfef2c4

I'm not sure if there is something I'm doing wrong? I followed the youtube tutorial by Darren to get this far, but when I did the ping test, it looped on until I force the terminal to quit.

Let me know if you have any suggestions, and thanks for the help in advance,

Daren

Link to comment
Share on other sites

Here's what I got. I haven't been able to use this thing yet, so I'm not exactly sure what it'll look like if there is something wrong on there or not. It seems whenever I plug the wifi pineapple in, I cannot access the Internet, even though my computer prioritizes a wifi connection.

daren@Hal:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:23:5a:9d:64:0c
inet addr:172.16.42.42 Bcast:172.16.42.255 Mask:255.255.255.0
inet6 addr: fe80::223:5aff:fe9d:640c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:163 errors:0 dropped:0 overruns:0 frame:0
TX packets:37 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9802 (9.8 KB) TX bytes:7772 (7.7 KB)

eth1 Link encap:Ethernet HWaddr 00:21:00:e8:95:9b
inet addr:192.168.0.102 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::221:ff:fee8:959b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:492 errors:0 dropped:0 overruns:0 frame:19245
TX packets:180 errors:13 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:61998 (61.9 KB) TX bytes:21544 (21.5 KB)
Interrupt:18

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2633 (2.6 KB) TX bytes:2633 (2.6 KB)

Link to comment
Share on other sites

You'll have an easier time if you just tell your pineapple to connect to your network through Wifi.

That being said post your iwconfig and you shouldn't have eth0&eth1. Your pineapple is plugged directly into your computer correct and you only have one Ethernet card?

Edited by zz2Fac3zz
Link to comment
Share on other sites

I changed it from wlan0 to wlan1, and still got the same issue.

The pineapple is connected directly to my pc, which does only have one ethernet port. Is there another setting that I should be changing?

Thanks again for the help, sorry for being so nooby.

Link to comment
Share on other sites

Pineapple Netmask: 255.255.255.0
Pineapple Network: 172.16.42.0/24
Interface between PC and Pineapple: eth0
Interface between PC and Internet: eth1
Internet Gateway: 192.168.0.1
(I assume)
IP Address of Host PC: 172.16.42.42
IP Address of Pineapple: 172.16.42.1


This should work if you use these settings based on ifconfig, let us know if it works and if you want more information about how to work it all out.

Its pretty simple but if you dont know it can look like a whole bunch of nothing.

Good Luck :D

Edited by markcoker
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...