Jump to content

Wlan 0 doesn't enable.


User8767
 Share

Recommended Posts

Hello everyone. I'm currently having trouble with client mode on the wi-Fi pineapple. My problem is that when I try to enable wlan0 on the network tile it doesn't allow me to. I can see in the URL bar that it tries to do this but instead of initializing/ enabling wlan0 it just refreshes the bar. I will attach a link to an image of this below.

post-46133-0-62619000-1391178889_thumb.p

I hope that someone here can help me with the problem and thank you for any help you might be able to give.

Thanks, Tekk3y.

Edited by Tekk3y
Link to comment
Share on other sites

your config is wrong (95% sure haha)

use this command below, then upload the file located in /sd called network-settings.txt to this forum:

cat /etc/config/network && cat /etc/config/wireless > /sd/network-settings.txt


(just be sure to clear out your wifi passwords(if any) :P)

Good Luck!

Link to comment
Share on other sites

you just use something like filezilla to grab the files via ssh off the pineapple its located in the directory /sd (the sd card is mounted there).

if your not sure how to do this, let me know what operating system your running, eg: windows.

Edited by markcoker
Link to comment
Share on other sites

...Its says I dont have permission to attach a txt file so I will copy and past the text below, thanks.

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11ng'
option macaddr '00:13:37:a5:08:99'
option htmode 'HT20'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option macaddr '00:13:37:81:42:c0'
option channel '8'
config wifi-iface
option device 'radio1'
option network 'wan'
option mode 'sta'
option encryption 'mixed-psk+ccmp+tkip'
option ssid 'VM874591-2G'
option key -Taken out-
Link to comment
Share on other sites

sorry i didnt have the right command up the top, ive corrected it here:
cat /etc/config/network > /sd/network-settings.txt && cat /etc/config/wireless > /sd/network-settings.txt

or you can just copy from screen:

cat /etc/config/network

also im having issues with my pineapple (sd card not mounted) could you show me what information there is if you type mount.

Thanks!

Edited by markcoker
Link to comment
Share on other sites

The contents of network are below:

# Copyright © 2006 OpenWrt.org
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 172.16.42.1
option netmask 255.255.255.0
option gateway 172.16.42.42
option dns 8.8.8.8
config interface wan
option ifname wlan1
option proto dhcp
config interface usb
option ifname usb0
option proto dhcp
config interface wan2
option ifname ' '
option proto ' '
option service ' '
option device ' '
option apn ' '
option username ' '
option password ' '
option defaultroute ' '
option ppp_redial ' '
option peerdns ' '
option dns ' '
option keepalive ' '
option pppd_options ' '
Thanks.
Link to comment
Share on other sites

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'none'
option ssid Pineapple5_0899
try adding this line to /etc/config/wireless, not sure but it might help.

then just reboot or put device up.
Edited by markcoker
Link to comment
Share on other sites

Also when I type in ifconfig, wlan0 doesn't come up. I also dont see where you want me to type mount for you.

Tekk3y.

both commands are over ssh at the prompt.

ifconfig wlan0 down && ifconfig wlan0 up

mount

Link to comment
Share on other sites

This is what is in my log:

Jan 31 18:01:27 Pineapple user.notice firewall: Reloading firewall due to ifup of wan (wlan1)
Jan 31 18:01:27 Pineapple daemon.notice netifd: Interface 'wan' is now up
Jan 31 18:01:27 Pineapple daemon.info dnsmasq[1732]: using local addresses only for domain lan
Jan 31 18:01:27 Pineapple daemon.info dnsmasq[1732]: using nameserver 8.8.8.8#53
Jan 31 18:01:27 Pineapple daemon.info dnsmasq[1732]: reading /tmp/resolv.conf.auto
Jan 31 18:01:24 Pineapple kern.info kernel: [ 769.610000] wlan1: associated
Jan 31 18:01:24 Pineapple kern.info kernel: [ 769.570000] wlan1: RX AssocResp from 10:0d:7f:18:07:e8 (capab=0x411 status=0 aid=8)
Jan 31 18:01:24 Pineapple kern.info kernel: [ 769.570000] wlan1: associate with 10:0d:7f:18:07:e8 (try 1/3)
Jan 31 18:01:24 Pineapple kern.info kernel: [ 769.540000] wlan1: authenticated
Jan 31 18:01:24 Pineapple kern.info kernel: [ 769.530000] wlan1: send auth to 10:0d:7f:18:07:e8 (try 1/3)
Jan 31 18:01:24 Pineapple kern.info kernel: [ 769.240000] wlan1: authenticate with 10:0d:7f:18:07:e8

And this is whats in my wireless file:

wireless.cfg063579.up=1
wireless.cfg063579.ifname=wlan1
...Thanks for the help.
Link to comment
Share on other sites

Has your wifi ever worked, when did you get this pineapple?

try this also, just copy what it outputs

airmon-ng start wlan0

Not sure, its a bit werid, if you dont mind loosing most things just restore your firmware.

WiFi Pineapple MK5 > Firmware Upgrade > Check for upgrade > Re-Flash

https://wifipineapple.com/?flashing


​Warning:
Flashing a firmware upgrade will wipe all data on your pineapple. It will not wipe the SD card, but please make sure you have one inserted.
Please also make sure that you have stopped all active services and infusions. To be sure, we recommend to re-boot the WiFi Pineapple MKV before any upgrade to ensure extra proccesses have been halted properly. Additionally, you should only perform a flash on a stable power connection, the wall adapter is recommended. You should also only flash over ethernet.
Finally, please give the flashing process some time. Interrupting it by pulling the power or closing the webinterface can result in a soft-brick.
Edited by markcoker
Link to comment
Share on other sites

Tekk3y,

Try conneting you wlan1 with the Client Mode tab to your home Access Point and go to the Pineapple Bar. Download the WiFi Manager and try using that to see how wlan0 is setup and whether or not it will allow you to enable it. It should be using the same commands on hardware that is in exactly the same state as that other button so I'm not convinced it will help but it's worth a shot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...