Jump to content

Snowballing issues. First odd wireless behavior then nothing at all.


AshiOni
 Share

Recommended Posts

Howdy

Been playing with my pineapple mark 5 for some time now. Everything was working well but all of a sudden I started having issues where karma just seemed to stop working (randomly), normally rebooting the device would solve the issue.

When it was working I noticed that I had two radio nics, wlan0 and wlan1.

When it stopped working I noticed there would be four radio nics, wlan0, wlan1, wlan2 and wlan3.

Rebooting would solve the issue. Meaning when I rebooted it would go back to only having wlan0 and wlan1. Randomly wlan2 and wlan3 would magically reappear.

After a couple of weeks of just assuming this was standard behavior the rebooting to fix the issue stopped working as well.

At which point I just started to run the "Factory Reset Pineapple" link within the GUI.

This worked for about a day at which point that has now stopped working as well and has developed new behaviors. When "Factory Reset Pineapple" was working to fix the radio problem I outlined above the device would say hey, I noticed you have orphan packages on this SSD, would you like to add those back in? It no longer does that as well as wlan1 no longer seems to be present when I do the factory reset. I have br0, eth0 and wlan0 interfaces only.

I'm not really sure what is supposed to be there or if some how the process I was following changed some how without me noticeing.

My next step is to format the SSD and re-install the firmware.

My question is: has anyone seen this behavior and figured out why it's happening.

I have looked over the forums a bit and see that a lot of people that seem to have the same sorts of issues, but nothing I have read so far has worked.

Thanks for your time.

EDIT

editing the /etc/config/wireless file to include the radio wlan1 seems to bring that back and makes it functional again.

Still need to understand why the wlan3 and wlan4 radios randomly appear and what is happening with the SSD.

Also, I'm now seeing yet another new behavior, the karma SSID name no longer remains persistent and the timezone resets if rebooted.

Edited by AshiOni
Link to comment
Share on other sites

Hopefully the new firmware will address some of those issues. Try the beta and note what has gotten better or worse. We all seem to be experiencing some quirky behavior from time to time.

I didn't update the firmware, maybe I will give that a shot, currently running 1.0.4

I did format the SD card and everything started working again. Not sure if there was some sort of corruption or what happening there but I'm able to use it with expected results again.

Thanks for the reply. I consider this issue resolved for now.

-Ashi

Link to comment
Share on other sites

1.0.4 is the latest, what infusions are installed? Its possible that something like wifi manager was messing with the settings.

With the following issue:

"I noticed you have orphan packages on this SSD, would you like to add those back in?"
i believe this happen because you did a "Factory Reset Pineapple" which wipes everything but the SD card, leaving the orphaned packages on the SD card (this is normal to my knowledge).

restoring to the latest firmware will fix most issues, as it wipes every clean and starts fresh. "
Factory Reset Pineapple" doesn't wipe everything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...